View Issue Details

IDProjectCategoryView StatusLast Update
0007217OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2021-04-02 14:03
Reporterd3 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.2.3 
Target VersionFixed in Version6.2.4 
Summary0007217: Save Remarks loses oxcreate date
DescriptionWhen I change and save an existing history entry (Remark) in the admin area, the previously set oxcreate date is removed. As this is a sorting criterion, the Remark entry is now sorted incorrectly.

Since the cause is in the preformatting of the create date, it may be that the behaviour only occurs with deviating date formats (e.g. dd.mm.YYY).
Steps To Reproduce- Open the admin panel
- set the German date format
- load an order / a user with history entries
- change the history entry and save it
- check the oxcreate value in the database
Additional InformationThe cause is in the pre-formatting of the date value. But instead of just changing the value, an incomplete field object is set. However, this is now missing the field type that ensures the appropriate back formatting when saving. Thus, the database receives incorrectly formatted values and rejects the field content.

"Data truncation: Incorrect datetime value: '16.04.2019 15:24:41' for column 'OXCREATE'"

I will create a pull request for this.
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
Database VersionNot defined

Activities

d3

2021-03-09 09:57

reporter   ~0013392

https://github.com/OXID-eSales/oxideshop_ce/pull/857

QA

2021-03-09 12:48

administrator   ~0013393

-- es --

anton.fedurtsya

2021-04-02 14:03

manager   ~0013414

The suggested pull request merged to b-6.2.x and up. Will be available with oxideshop CE 6.7.1 component.