View Issue Details

IDProjectCategoryView StatusLast Update
0007180OXID eShop (all versions)2.3. Extensions (modules, themes)public2020-10-08 15:22
Reporternitin.singh 
PriorityhighSeveritymajorReproducibilityunable to reproduce
Status closedResolutionunable to reproduce 
Product Version6.2.1 
Target VersionFixed in Version 
Summary0007180: Saving module settings issue, if module id includes - or / character
DescriptionWe have noticed a problem in Shop 6.2 while updating module settings.
We are not able to save module settings in Shop admin, if there is specific characters (- or /) exist in module id. e.g. OXPS-MyModule
Steps To ReproduceYou can simply follow these steps.
1. Please develop any simple module with module id including any one of these characters (- or /) and having some settings.
2. Install and enable this module.
3. Now please try to update any setting field from shop admin. You will notice that page is getting refreshed but setting is not updated on form and DB.
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP Version7.1
Database VersionOther

Activities

alfredbez

2020-10-05 14:27

reporter   ~0013313

We stumbled upon the same issue, but with OXID 6.2.2 and PHP 7.4. The module we used had a slash in its module-id. To change module settings you need to deactivate the module, change the settings and activate the module again.

Note also, that there are a ton of modules out there using a slash or a "-" in the module-id and this worked - perfectly until. Even OXID ships a few modules like this:
* https://github.com/OXID-eSales/cloud-dashboard-module/blob/e6db1750727cd6428dc2048dc9bec201bc9d92f6/metadata.php#L16
* https://github.com/OXID-eSales/graphql-account-module/blob/d28b38de999562dd47172ed3760fa66f778e8afe/metadata.php#L17
* https://github.com/OXID-eSales/graphql-base-module/blob/cfd0eafeb987abddb47c7734445fe60a2080ac3b/metadata.php#L19

QA

2020-10-05 16:29

administrator   ~0013315

I created a module with ID "oxs/test-module". Both characters are present, but I can still modify my setting successfully. As a result I am unable to reproduce the issue with the steps provided. Maybe there is another fact that interferes with the functionality. Did you test with a simple module as described and in a standard OXID eShop environment? If not, please do so.

[sp]

alfredbez

2020-10-08 13:42

reporter   ~0013324

We found out that it works after commenting out this line: https://github.com/OXID-eSales/oxideshop_ce/blob/v6.5.6/source/Internal/Container/Event/ConfigurationChangedEventSubscriber.php#L23

Nitin confirmed that, too. We reported that to some folks from the core team and they were able to reproduce the issue. The issue is not related to the fact, that the module-id has a "-" or a "/" in it, we were able to reproduce this with a module-id that contains only letters.

QA

2020-10-08 15:19

administrator   ~0013325

Thanks for the further investigation and report to Core Team. I will close this issue now, since you're telling it is not connected to the described characteristics.