View Issue Details

IDProjectCategoryView StatusLast Update
0007176OXID eShop B2B EditionB2B edition - subpublic2020-10-27 14:01
ReporterQA 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.0 
Target VersionFixed in VersionNext Minor Version 
Summary0007176: No update of shipping costs in basket
DescriptionShipping costs do not update correctly in the basket, but at step 4 in the checkout process. Looks like the methods to calculate basket values are not triggered the right way on update of the basket contents.
Steps To Reproduce- It's best to deactivate all existing shipping cost rules
- Then create a new shipping cost rule
- Set always active and condition to [price] >= [0] and<= [100]
- Set price surcharge to 20,00
- Assign it to the standard shipping method
- Login with a user who can order
- Search for product 3788 (should cost 24,95
- Put 4 of them into the basket
- Basket value should be 99,80
- Since you are under 100,00, you have shipping costs of 20,00
- Change amount of 3788 from 4 to 5 and click update
- Basket value should be 124,75
- Since you are over 100,00, you don't have any shipping costs
- Change amount of 3788 from 5 back to 4 and click update
- Basket value should be 99,80 again
- Since you are under 100,00, you SHOULD have shipping costs of 20,00
- But you still have no shipping costs (the unusual behavior)
- Click agin on update
- Now you have shipping costs of 20,00 again (which is correct behavior)

Note: A solution partner noticed this behavior the other way around. The shipping costs won't update if he increases the amount from 4 to 5. In his case, the shipping costs stay at 20,00, which is also wrong behavior.
Additional InformationThis behavior is only reproducable in an OXID eShop Enterprise B2B Edition (3.3.0 and 4.0.0). Reproduction in a standard Enterprise Edition was not possible. Therefore the issue seems connected to the B2B modules.

[sp]
TagsBasket, Calculations

Activities

r.victor

2020-10-09 12:55

reporter  

Bildschirmfoto_2020-10-09_um_12_45_36.png (488,183 bytes)

r.victor

2020-10-09 12:55

reporter   ~0013327

Same shipping cost bug with calculation rules "for each product". Shipping cost do not update correctly on logged user.

- activate all B2B module.
- login to frontend
- change amount article in basket

Shipping cost will not recalculate until you refresh twice.