View Issue Details

IDProjectCategoryView StatusLast Update
0007107module PayPal Plusmodule PayPal Plus - subpublic2020-03-26 10:56
Reporterresponsegmbh 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0007107: Long loading time in the backend order overview
DescriptionIf you have lots of orders with paypal plus payment, the loading time of the order overview is getting slower.

The reason is this database query:

select oxorder.*, pluspayments.oxdesc AS payments_oxdesc, payppaypalpluspui.oxid AS payppaypalpluspui_oxid
from oxorder
LEFT JOIN oxv_oxpayments_de AS pluspayments ON pluspayments.oxid = oxorder.oxpaymenttype
LEFT JOIN payppaypalpluspayment ON payppaypalpluspayment.OXORDERID = oxorder.OXID
LEFT JOIN payppaypalpluspui ON payppaypalpluspui.OXPAYMENTID = payppaypalpluspayment.OXPAYMENTID
where 1

File: modules/payp/paypalplus/controllers/admin/admin_payppaypalplusorder_list.php

If I comment the payppaypalplus.. tables out, the loading time will be much better.
Steps To Reproduce1. Maybe you need thousands of (PayPal Plus) orders with activated PayPal Plus module
2. Go to the order overview
3. You should see the long loading time

You can compare the loading time with deactivated module.
Additional InformationLoopback: https://forum.oxid-esales.com/t/langsames-backend-im-bereich-bestellubericht-vermutlich-durch-paypalplus-modul/94745/
TagsNo tags attached.

Activities

QA

2020-03-12 15:45

administrator   ~0013150

So this is not a bug in paypal plus module but much more a feature request for improvement of the loading time of the order overview
- es -

responsegmbh

2020-03-12 16:44

reporter   ~0013151

We have a customer who waits more than 2 minutes for a page when this module is active. It is frustrating.

marco_steinhaeuser

2020-03-12 22:05

administrator   ~0013152

> So this is not a bug in paypal plus module but much more a feature request for improvement of the loading time of the order overview
Not really sure about this as performance seems to decrease only in interconnection with PPP module. However, that should be checked more deeply, shouldn't it?

mario_lorenz

2020-03-19 15:18

developer   ~0013159

- Table indexes missing for extensive left-join SQL.
- After creating the indices, a significant boost in performance
- Fast solution: Add this SQL to Shop-DB via: OXID-Admin > Service > Tools > Execute SQL

ALTER TABLE `oxorder` ADD INDEX `OXPAYMENTTYPE` (`OXPAYMENTTYPE`);
ALTER TABLE `payppaypalpluspui` ADD INDEX `OXPAYMENTID` (`OXPAYMENTID`);

I will add this snippet to the module-install-routine. It will be published in the next maintenance-release of the module.

mario_lorenz

2020-03-26 10:04

developer   ~0013164

Fix in Version 3.0.4 installable via composer:

composer require oxid-professional-services/paypalplus-module

payppaypalplus_v3.0.4.zip (3,329 bytes)