View Issue Details

IDProjectCategoryView StatusLast Update
0007019OXID eShop (all versions)4.01. Database handlingpublic2019-08-20 10:14
Reportersimon.runer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version6.0.5 
Target VersionFixed in Version 
Summary0007019: OXSOLDAMOUNT cannot be used for product sorting in category view in a multishop-environment
Descriptionsee 0007015 which was wrongly closed

If I add the field to $this->aMultishopArticleFields in condig.inc.php it won't work..
Changes to OXSOLDAMOUNT are written directly to the oxarticle table here:

https://github.com/OXID-eSales/oxideshop_ce/blob/9d4e24a16d63f159d9044c1c28791e61837c2d71/source/Application/Model/Article.php#L2222

When sorting the value is read from oxfield2shop where it is 0.
Steps To Reproduce- Set up a multishop-environment with one master shop (oxshopid = 1) and 2 subshops (oxshopid = 2 and oxshopid = 3)
- If necessary add OXSOLDAMOUNT to $this->aMultishopArticleFields in condig.inc.php and to db table oxfield2shop
- buy 1 piece of a product in shop with oxshopid = 2
- buy 1 piece of the same product in shop with oxshopid = 3
- check OXSOLDAMOUNT in oxarticles and in oxfield2shop
- Should be 1 for each entry in oxfield2shop with oxshopid = 2 and 3 but is 0 for both
- Not sure what it is supposed to be in oxarticles, but it is 2

Let's say you sell the product a lot more often in one shop, sorting via OXSOLDAMOUNT for sure will not be correct in the other shop.
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP Version7.0
MySQL Version5.7

Relationships

duplicate of 0007015 closed OXSOLDAMOUNT in Multishop-Umfeld nicht für Artikelsortierung geeignet. 

Activities

QA

2019-08-20 10:11

administrator   ~0012967

for inherited articles, the oxsoldamount from the oxarticles is always used for article list sorting. If now an article is bought in one of the three subshops, the oxsoldamount is also increased by this purchased number in the oxarticles, regardless of which subshop it was bought in.

There is already a bug entry, which was also closed.
https://bugs.oxid-esales.com/view.php?id=7015


- es -