View Issue Details

IDProjectCategoryView StatusLast Update
0007015OXID eShop (all versions)2.4. Administer productspublic2019-08-05 11:51
Reportersimon.runer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version6.0.3 
Target VersionFixed in Version 
Summary0007015: OXSOLDAMOUNT in Multishop-Umfeld nicht für Artikelsortierung geeignet.
DescriptionAuch wenn man das Feld in $this->aMultishopArticleFields aufnimmt, bringt das nichts.
Änderungen an OXSOLDAMOUNT werden hier direkt in oxarticles geschrieben.

https://github.com/OXID-eSales/oxideshop_ce/blob/9d4e24a16d63f159d9044c1c28791e61837c2d71/source/Application/Model/Article.php#L2222

"Gelesen" wirds dann aber von oxfield2shop und da steht immer 0 drin.
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Activities

QA

2019-07-31 13:00

administrator   ~0012954

Contents in the bugtracker have to be entered in English, because an international team of developers takes care of the bug handling.
Therefore I would like to ask you to translate your entries and add the steps to reproduce.
Thx in advance.

simon.runer

2019-08-05 09:49

reporter   ~0012956

Sorry, but I cannot edit the issue anymore but here is the english version:

Title: OXSOLDAMOUNT cannot be used for product sorting in category view in a multishop-environment

If I add the field to $this->aMultishopArticleFields in condig.inc.php it won't work..
Changes to OXSOLDAMOUNT are written directly to the oxarticle table here:

https://github.com/OXID-eSales/oxideshop_ce/blob/9d4e24a16d63f159d9044c1c28791e61837c2d71/source/Application/Model/Article.php#L2222

When sorting the value is read from oxfield2shop where it is 0.

QA

2019-08-05 11:49

administrator   ~0012957

Last edited: 2019-08-05 11:51

View 2 revisions

In an OXID eShop 6.1.4 I set oxsoldamount to 100 for the article Kite Core GTS and to 99 for the article Kite Core GT in the oxarticles table and activated the article sorting for oxsoldamount.
The articles were also displayed correctly sorted afterwards.
Therefore I close this bug entry as "not reproducable".

 -es-

QA

2019-08-05 11:50

administrator  

oxsoldamount.JPG (110,031 bytes)
oxsoldamount.JPG (110,031 bytes)