View Issue Details

IDProjectCategoryView StatusLast Update
0006988OXID eShop (all versions)2.4. Administer productspublic2019-08-20 10:17
ReporterDayanaLuedecke 
PrioritylowSeveritytrivialReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version6.1.3 
Target VersionFixed in Version 
Summary0006988: Shop offline when copying an article
DescriptionWhen copying an article, an error occured.

In logfile a duplicate entry is logged for OXMAINIDX at insert into oxobject2category. You can reproduce with articles associated more than one category. If there is only one category associated you dont get an error.
Steps To ReproduceChoose an article. Associate to more than one category. Click "Copy article".
TagsMySQL
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Activities

QA

2019-05-29 15:19

administrator   ~0012901

Last edited: 2019-05-31 08:12

View 2 revisions

I couldn't reproduce the behavior. I created an article and assigned it to two categories. Then I clicked Copy Article.
Then you get the message Article number already exists. Changing the article number and saving, transfers the article to the database.
The index "OXMAINIDXU" is formed from
OXCADNID
OXOBJECTID
OXSHOPID
However, here the OXOBJECTID differs for both index entries in the oxobject2category. Therefore I don't get a duplicate entry. Bug will be closed as not reproducable.


-ES

marco_steinhaeuser

2019-08-13 14:47

administrator   ~0012959

ES, can you pls re-check this issue? It is based on this forum entry:
https://forum.oxid-esales.com/t/bugverdacht-artikel-kopieren-bingt-shop-offline/95144

Apparently, the corpus delicti is not the duplication of the product item but the format of the saved "->" into its entity "->". There's even a module to fix this behaviour:
https://github.com/eComStyle/FixSmartyInContent

QA

2019-08-13 15:44

administrator   ~0012960

Can not reproduce it.
1. Add article to two categories
2. Dublicate article four times
3. Search for article in frontend
4. No maintainance mode

See screenshots

Bug_2.JPG (53,481 bytes)
Bug_2.JPG (53,481 bytes)
Bug_3.JPG (131,302 bytes)
Bug_3.JPG (131,302 bytes)
Bug_1.JPG (187,825 bytes)
Bug_1.JPG (187,825 bytes)

DayanaLuedecke

2019-08-14 08:16

reporter   ~0012961

Please try in PE or CE. We can reproduce it in 3 Shops (2 CE 6.1.4 and 1 PE 6.1.4)

Article already exists, with one Category we cant copy, with second or more categories the iframe shows offline.html

DayanaLuedecke

2019-08-14 08:21

reporter  

QA

2019-08-14 10:56

administrator   ~0012962

I tried to reproduce with an standard PE Shop, but everything works fine.
Existing article with one category can also be copied as an article with two or more categories assigned.
See Screenshot.

Please try with an standard installation where systemrequirements are met.

Bug_4.JPG (349,203 bytes)

DayanaLuedecke

2019-08-14 13:25

reporter   ~0012963

Please try in a migrated Shop, migrated from 4.10.x to 6.0 or higher.

Think its a Problem with Migration. Maybe a unique in Database?

QA

2019-08-14 14:26

administrator   ~0012964

Hello Mrs. Luedecke, you would have to install a standard shop 4.10.x yourself and then migrate to the current 6.1.4 to see if the behavior you described occurs.
I could not reproduce the behavior across all installed standard instances EE, PE, CE). If you can reproduce it, please describe the steps to reproduce exactly.
We would then verify it and escalate it to shop development if necessary.

DayanaLuedecke

2019-08-16 13:45

reporter   ~0012965

Last edited: 2019-08-16 14:11

View 3 revisions

We already have migrated some shops from 4.10.7 to 6.0 and higher and can reproduce in all shops. We cant reproduce in a fresh installed 6.1.4, so it seems to be a problem in database migration.

Exception Log:
[2019-08-14 07:58:33] OXID Logger.ERROR: Duplicate entry 'f0a567b6170167db6f6c19442b6b3772' for key 'OXMAINIDX' ["[object] (OxidEsales\\Eshop\\Core\\Exception\\DatabaseErrorException(code: 1062): Duplicate entry 'f0a567b6170167db6f6c19442b6b3772' for key 'OXMAINIDX' at /home/waebkxuy/_dev/vendor/oxid-esales/oxideshop-ce/source/Core/Database/Adapter/Doctrine/Database.php:938, Doctrine\\DBAL\\Exception\\UniqueConstraintViolationException(code: 0): An exception occurred while executing 'insert into oxobject2category (oxid, oxobjectid, oxcatnid, oxtime) VALUES ('71c9e2d27f5268097a2e0f5f6ea275fb', 'f0a567b6170167db6f6c19442b6b3772', '', '') ':\n\nSQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'f0a567b6170167db6f6c19442b6b3772' for key 'OXMAINIDX' at /home/waebkxuy/_dev/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php:66, Doctrine\\DBAL\\Driver\\PDOException(code: 23000): SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'f0a567b6170167db6f6c19442b6b3772' for key 'OXMAINIDX' at /home/waebkxuy/_dev/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:59, PDOException(code: 23000): SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'f0a567b6170167db6f6c19442b6b3772' for key 'OXMAINIDX' at /home/waebkxuy/_dev/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:57)\n[stacktrace]\n#0 /home/waebkxuy/_dev/vendor/oxid-esales/oxideshop-ce/source/Core/Database/Adapter/Doctrine/Database.php(779): OxidEsales\\EshopCommunity\\Core\\Database\\Adapter\\Doctrine\\Database->convertException(Object(Doctrine\\DBAL\\Exception\\UniqueConstraintViolationException))\n#1 /home/waebkxuy/_dev/vendor/oxid-esales/oxideshop-ce/source/Core/Database/Adapter/Doctrine/Database.php(576): OxidEsales\\EshopCommunity\\Core\\Database\\Adapter\\Doctrine\\Database->executeUpdate('insert into oxo...', Array)\n#2 /home/waebkxuy/_dev/vendor/oxid-esales/oxideshop-ce/source/Application/Controller/Admin/ArticleMain.php(386): OxidEsales\\EshopCommunity\\Core\\Database\\Adapter\\Doctrine\\Database->execute('insert into oxo...')\n#3 /home/waebkxuy/_dev/vendor/oxid-esales/oxideshop-ce/source/Application/Controller/Admin/ArticleMain.php(306): OxidEsales\\EshopCommunity\\Application\\Controller\\Admin\\ArticleMain->_copyCategories('0014718754a146c...', 'f0a567b6170167d...')\n#4 /home/waebkxuy/_dev/vendor/oxid-esales/oxideshop-ce/source/Core/Controller/BaseController.php(524): OxidEsales\\EshopCommunity\\Application\\Controller\\Admin\\ArticleMain->copyArticle()\n#5 /home/waebkxuy/_dev/vendor/oxid-esales/oxideshop-ce/source/Core/ShopControl.php(332): OxidEsales\\EshopCommunity\\Core\\Controller\\BaseController->executeFunction('copyArticle')\n#6 /home/waebkxuy/_dev/vendor/oxid-esales/oxideshop-ce/source/Core/ShopControl.php(274): OxidEsales\\EshopCommunity\\Core\\ShopControl->executeAction(Object(agcms_texteditor), 'copyArticle')\n#7 /home/waebkxuy/_dev/vendor/oxid-esales/oxideshop-ce/source/Core/ShopControl.php(137): OxidEsales\\EshopCommunity\\Core\\ShopControl->_process('OxidEsales\\\\Esho...', 'copyArticle', NULL, NULL)\n#8 /home/waebkxuy/_dev/source/modules/aspaypal/aspaypal_shopcontrol.php(44): OxidEsales\\EshopCommunity\\Core\\ShopControl->start('article_main', 'copyArticle', NULL, NULL)\n#9 /home/waebkxuy/_dev/vendor/oxid-esales/oxideshop-ce/source/Core/Oxid.php(26): aspaypal_shopcontrol->start()\n#10 /home/waebkxuy/_dev/source/index.php(15): OxidEsales\\EshopCommunity\\Core\\Oxid::run()\n#11 /home/waebkxuy/_dev/source/admin/index.php(11): require_once('/home/waebkxuy/...')\n#12 {main}\n"] []

We tried again. The Copy of the article is made but without Categories an in database there is one entry for Article-Copy in oxobject2category with empty oxcatnid. And thats the error. While copying the category/categories get lost.
An exception occurred while executing 'insert into oxobject2category (oxid, oxobjectid, oxcatnid, oxtime) VALUES ('88fe5681ad2a6e3b3ae4b74453f467d0', 'a75c52615125257cf8ad2bf0403bd6e4', '', '')

DayanaLuedecke

2019-08-19 16:29

reporter   ~0012966

bitte schlie├čen, habbe heute nochmal komplett durchgetestet, der Fehler kommt aus dem Basis-Modul von digidesk, ist ab der neusten Version behoben