View Issue Details

IDProjectCategoryView StatusLast Update
0006821OXID eShop (all versions)2.3. Extensions (modules, themes)public2018-04-30 09:59
Reportersmxsm 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionopen 
Product Version6.0.2 
Target VersionFixed in Version 
Summary0006821: Wrong loading order of EE specific admin templates in OXID EE 6.x?
DescriptionAdmin templates in the folder

source/Application/views/admin/tpl ( = SHOP_EE)

will ONLY be found by the shop IF the corresponding template is NOT also in the folder

vendor/oxid-esales/oxideshop-ee/Application/views/admin/tpl (= VENDOR_EE)

Background:

all admin templates are located in

vendor/oxid-esales/oxideshop-ce/source/Application/views/admin/tpl (= VENDOR_CE)

and only templates that differ for EE, are also located in VENDOR_EE (e.g "article_main.tpl")

It looks like OXID is looking for templates in this particular order:

VENDOR_EE -> SHOP_EE -> VENDOR_CE

and NOT, how it *should* be in our opinion:

SHOP_EE -> VENDOR_EE -> VENDOR_CE
Steps To Reproduce- Choose a template which is located in SHOP_EE and in VENDOR_EE (e.g. article_main.tpl)
- Add a different text to both templates (e.g. "IN SOURCE" and "IN VENDOR") to see which one gets loaded
- empty cache
- check the template in the backend: you will see the text from the VENDOR_EE template, and NOT the text from the SHOP_EE template!
- rename the template in VENDOR_EE
- empty cache again
- now you will the the expected added text from the SHOP_EE template
TagsAdmin
ThemeOther
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Relationships

related to 0006822 acknowledgedbenjamin.joerger Admin templates can't be changed in source if they are overwritten in pe/ee 

Activities

QA

2018-04-27 16:32

administrator   ~0012456

Last edited: 2018-04-27 16:32

View 2 revisions

Thank you for your report.

OXID eShop 6 EE looks up the files in the following order:

1) oxideshop-ee
2) oxideshop-pe
3) source

The files in source are a copy of the oxideshop-ce project. This in mind, you will notice, that the look up order has to be like this. If the order will be changed as suggested, the templates from source will be used anytime, even if an extended one is available in oxideshop-pe/ee.

This issue will be closed, but another one was reported, because the actual look up order can lead into some problems with adding blocks to admin templates (see related issue).

[sp]