View Issue Details

IDProjectCategoryView StatusLast Update
0006809Flow themeThemepublic2018-03-22 11:21
Reportermarco_steinhaeuser 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.3.3 
Target VersionFixed in Version3.0.0 
Summary0006809: selection lists don't work in checkout (cart)
DescriptionIf the following option is activated:
master settings -> core settings -> perform -> Load Selection Lists in Product Lists

selection lists don't work in cart (1st checkout step). Additionally, the values appear in the footer.
Steps To Reproducedo as described in description ;)
Additional InformationThis is because JS doesn't work properly here. The following code fixed it:

    $( '.basketItemDesc .selectorsBox .dropdown-menu li a', $oDetailsWrapper ).click( function( e )
        {
            e.preventDefault();
            var $this = $( this );
            $this.closest( '.selectbox' ).removeClass( 'open' );
            $this.parent().parent().prev().val( $this.attr( 'data-selection-id' ) );
            $this.parent().parent().prev().siblings( 'button' ).find( 'span' ).first().text( $this.text() );
        }
    );
TagsSolution Provided

Activities

marco_steinhaeuser

2018-03-15 21:33

reporter  

marco_steinhaeuser

2018-03-15 21:34

reporter   ~0012422

https://forum.oxid-esales.com/t/auswahllisten-funktionieren-im-warenkorb-nicht/93238

anton.fedurtsya

2018-03-22 11:21

administrator   ~0012427

Pull request merged to master. Will be available with next release.