View Issue Details

IDProjectCategoryView StatusLast Update
0006739OXID eShop (all versions)1.10. RSSpublic2018-01-29 14:33
Reportermarco_steinhaeuser 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.0.0 
Target VersionFixed in Version6.0.1 
Summary0006739: RSS feed for categories not sorted desc by time
DescriptionThe RSS feed for categories is not sorted descending by time (although it should).
Steps To ReproduceAdd a product to https://demoshop.oxid-esales.com/community-edition/rss/Kategorie/Wakeboards/
Additional InformationThe problem seems to be that the RSS feed is sorted by oxobject2category:oxtime which always contains a "0", if assigned to a main category.
https://github.com/OXID-eSales/oxideshop_ce/blob/master/source/Application/Model/RssFeed.php#L543
TagsRSS, Sorting
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Activities

marco_steinhaeuser

2017-12-07 21:37

administrator   ~0012313

Proudsourcing is using product items as blog post articles that shall be imported to OXIDforge. This doesn't work any more using any syndication tool - of course, other cases are affected, too.

tabsl

2017-12-07 21:50

reporter   ~0012315

https://github.com/OXID-eSales/oxideshop_ce/pull/615