View Issue Details

IDProjectCategoryView StatusLast Update
0006578Flow themeThemepublic2018-09-20 09:58
Reporterkeywan.ghadami 
PrioritynormalSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.2 
Summary0006578: Javascript error on mobile device on detail page breaks swipe
DescriptionIn mobile view on detail page there is an error that stops javascript from working.

Steps To Reproduce1. mobile view (e.g. chrome F12, mobile symbol)
2. open/reload detail page e.g.
http://demoshop.oxid-esales.com/professional-edition/Kiteboarding/Kiteboards/Kiteboard-CABRINHA-CALIBER-2011.html
3. look at the browser console you see something like:
Uncaught ReferenceError: Carousel is not defined
    at HTMLDocument.<anonymous> (details.min.js?1477089128:1)
    at k (jquery.min.js?1477089128:2)
    at Object.fireWith [as resolveWith] (jquery.min.js?1477089128:2)
    at Function.ready (jquery.min.js?1477089128:2)
    at HTMLDocument.g (jquery.min.js?1477089128:1)
(anonymous) @ details.min.js?1477089128:1
k @ jquery.min.js?1477089128:2
fireWith @ jquery.min.js?1477089128:2
ready @ jquery.min.js?1477089128:2
g @ jquery.min.js?1477089128:1
4. click on an image, it will leave the page instead of opening a slider
Additional Information1.
the problem is in detail.js,
the code asks for
if (window.isMobileDevice() )
and then calls "Carousel" which is not defined
 new Carousel( '#swipe-overlay' );
a good workaround might be to drop the if statement.

2. the java script error may cause additional effects, e.g. modules and other javascript might fail because of this issue, so please keep the severity to at least critical.
TagsSolution Provided

Relationships

has duplicate 0006881 closedQA Flow theme Simple selection list in products view - doesn't work on mobile devices 
has duplicate 0006675 acknowledgedvilma_liorensaityte OXID eShop (all versions) article details - product image slider/carousel is not fully working 

Activities

keywan.ghadami

2017-01-30 16:37

developer   ~0011952

To make it work i also removed the condition in the productmain.tpl, so it will always init things: [{oxscript add="\$( document ).ready( function() { Flow.initDetailsEvents(); });"}].

keywan.ghadami

2017-01-30 17:01

developer   ~0011953

pull request:
https://github.com/OXID-eSales/flow_theme/pull/81
https://github.com/OXID-eSales/flow_theme/pull/82

anton.fedurtsya

2018-04-20 18:32

manager   ~0012454

Pull requests analyzed, tested and merged. Thanks.