View Issue Details

IDProjectCategoryView StatusLast Update
0006501OXID eShop (all versions)2.2. Shop settingspublic2016-09-30 14:52
Reporterleofonic 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.10.1 / 5.3.1 
Target VersionFixed in Version4.10.2 / 5.3.2 
Summary0006501: Discounts not possible for products with variants
DescriptionProbably since Resolution of bug 0006027 not buyable parents are not only hidden when choosing a product for discount type "item", but also when selecting the products which will be discounted (tab products, assign products).
Steps To ReproduceIn demoshop discounts, try to create a 10% discount for jeans "anna".
TagsDiscount, Solution Provided, Variants
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Relationships

has duplicate 0006529 closedQA Certain article cannot be assigned to discounts 

Activities

QA

2016-09-08 14:54

administrator   ~0011769

Unfortunately I can't reproduce this.

Did you activate the checkbox "Display Variants in Assignment Lists in eShop admin", which you find right above the checkbox ""Parent" Products can be purchased"? You find it in the administration area -> core settings -> system -> variants.

If both checkboxes are activated, then the variants and the parent article are listed. If I deactivate "parent can be purchased", then only the variants are shown. If I deactivate the checkbox "display variants in...", too, I get the behavior which you have described.

leofonic

2016-09-08 15:39

reporter   ~0011770

Unbuyable parents can not be selected anymore which is bad.

Reporter in 0006027 says it is wrong that you can assign an unbuyable item as a discount. He does not say it is wrong to assign an unbuyable parent to a discount. It is a good thing if unbuyable parents can be assigned, just as you can assign categories, which are also not buyable.

Category assigned: discount valid for all products in category
Parent assigned: discount valid for all variants

There are two changed files in the commit https://github.com/OXID-eSales/oxideshop_ce/pull/390/files
DiscountItemAjax.php that fixes the reported bug
DiscountArticlesAjax.php changes should be reverted

michael_keiluweit

2016-09-14 09:31

developer   ~0011782

Hi leofonic,

thank you for your feedback. I created a new PR (485) with your suggested changes. The class DiscountArticleAjax is reverted. Now the unbuyable parents are listed and selectable again.


https://github.com/OXID-eSales/oxideshop_ce/pull/485

robert blank

2016-09-30 14:50

manager   ~0011811

Pull request was merged with https://github.com/OXID-eSales/oxideshop_ce/commit/fca2fa8ee8cc3f0cb7c5147da91d56817e005368