View Issue Details

IDProjectCategoryView StatusLast Update
0006205OXID eShop (all versions)1. ----- eShop frontend -----public2015-10-28 15:02
Reporterd3 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.9.5 / 5.2.5 
Target VersionFixed in Version4.8.10 / 5.1.10 
Summary0006205: PHP Fatal error: Call to a member function getLink() on a non-object
Descriptionthere are no checks if object really exists in details::_getVendorBreadCrumb

SK
Steps To Reproducestep 1: add an accessories:
eShop Admin -> Administer Products -> Products -> Kuyichi Lederg├╝rtel JEVER -> Crosssell. -> Assign Accessories -> Kite Core GTS (Art.Nr 1208)

step 2: remove category assignments:
eShop Admin -> Administer Products -> Products -> Kite Core GTS (Art.Nr 1208) -> Extended -> Assign Categories -> Unassign all

step 3: add distributor (vendor) and remove manufacturer :
eShop Admin -> Administer Products -> Products -> Kite Core GTS (Art.Nr 1208) -> Main
Distributor -> www.true-fashion.com
Manufacturer -> select "---"
-> Save


Frontend
Homepage -> change to product detailspage: Kuyichi Lederg├╝rtel JEVER (Week's Special)
-> at detailspage -> Accessories -> klick product "Kite Core GTS" (Art.Nr 1208)

As result you can see an incomplete page.

the cause for that is:
PHP Fatal error: Call to a member function getLink() on a non-object in /path/to/shop/application/controllers/details.php on line 1580 (line can vary)

TagsNo tags attached.
ThemeAzure
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Activities

QA

2015-07-30 16:45

administrator   ~0011153

Thank you for the detailled information on how to reproduce this issue.