View Issue Details

IDProjectCategoryView StatusLast Update
0006013OXID eShop (all versions)4.12. Subshop handlingpublic2015-01-09 08:04
Reporterkeywan.ghadami 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0006013: Login not posible
DescriptionLogin in one subshop is not possible for users if they have the username in different subshops.

Reason is that the salt will be fetched by the username without shopid.

Additional Information
- $sSalt = $oDb->getOne("SELECT `oxpasssalt` FROM `oxuser` WHERE `oxusername` = " . $oDb->quote($sUser));

+ $sSalt = $oDb->getOne("SELECT `oxpasssalt` FROM `oxuser` WHERE `oxusername` = " . $oDb->quote($sUser) . " AND `oxshopid` = " . $oDb->quote( $sShopID ));
TagsNo tags attached.
ThemeAll
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0005988 resolvedtomas_liubinas User cannot login in subshop 

Activities

jurate.baseviciene

2015-01-09 08:01

reporter   ~0010596

Reminder sent to: keywan.ghadami

Hi,

Thank you very much for submitting this issue. We already fixed this problem and fix will included to the next patch release.

Best regards,
Jurate