View Issue Details

IDProjectCategoryView StatusLast Update
0005988OXID eShop (all versions)4.12. Subshop handlingpublic2015-01-07 17:27
Reportermartinwegele 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.9.2 / 5.2.2 
Target Version4.9.3 / 5.2.3Fixed in Version4.9.3 / 5.2.3 
Summary0005988: User cannot login in subshop
DescriptionIf you register with the same credentials in the subshop as in the mastershop you cannot login in the subshop with those credentials. In the mastershop the credentials work fine.
Steps To ReproduceInstall EE5.2.2
Create a subshop
Activate the subshop
Register as a new user in the mastershop (#1) -> you will be logged in
Register as a new user in the subshop (#2) ->you will be logged in
but once you click somewhere you will be logged out.
Now logout in the mastershop and login again. -> works fine
Try the same in the subshop -> the shop will always say that the credentials are wrong.
TagsSubshops
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0005992 resolvedjurate.baseviciene It is not possible to loggin with the same username to few subshops (only EE) 
has duplicate 0006013 resolvedjurate.baseviciene Login not posible 
related to 0006111 resolvedHR Multishop: users with the same login ( but different oxpasssalt ) can't login in subshop 

Activities

jurate.baseviciene

2014-12-05 11:51

reporter   ~0010383

Last edited: 2014-12-10 15:54

View 2 revisions

Hi,
Additional information for reproduce steps:
Need to use the same email for registration to master shop and to subshop.

Test case
1) Create few subshop: Shop1 and Shop2;
2) Register with the same username to Shop1
3) And later to Shop2
4) Login to Shop1 with this username, you will be logged in.
5) Login to Shop2 with the same username, you will get wrong password error.

tomas_liubinas

2015-01-07 17:26

reporter   ~0010593

Fix:
https://github.com/OXID-eSales/oxideshop_ce/commit/ad8273967cb8394f32ba7b8da55774555b0f41c9