View Issue Details

IDProjectCategoryView StatusLast Update
0005902OXID eShop (all versions)2.4. Administer productspublic2014-11-11 09:02
Reporterleofonic 
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.9.0 / 5.2.0 
Target Version4.9.2 / 5.2.2Fixed in Version4.9.2 / 5.2.2 
Summary0005902: Variants can't be deactivated
DescriptionVariants can be activated but not deactivated.
Steps To ReproduceIn Demoshop, log into backend, go to an article with variants, deselect some active variants, click "save variants", variants are still active.
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

tadas

2014-10-30 17:20

reporter   ~0010295

Tried on demo shop and was unable to reproduce. Although the issue might be, that "save selection" button is being clicked instead of "save variants". Former is on the top, and later is on the bottom. With a lot of variants, "save variants" is not visible initially (requires scrolling down).

leofonic

2014-10-30 18:52

reporter   ~0010296

Reproduced on demoshop: https://www.youtube.com/watch?v=2_7-2kdHoiU

marco_steinhaeuser

2014-11-03 14:30

administrator   ~0010305

Thanks @leofonic, youtube is always a nice idea :-)
This bug shall be fixed immediately. The fix shall be available here at the bugtracker as either file download or description. Will be released with 5.2.2 (4.9.2) by the end of November.

vilma_liorensaityte

2014-11-11 09:02

administrator   ~0010323

Fixed in admin controller article_variant::savevariant() method.
First add checkbox logic and only later check if something was changed for variant:

        // checkbox handling
        if (is_array($aParams) && !isset($aParams['oxarticles__oxactive'])) {
            $aParams['oxarticles__oxactive'] = 0;
        }

        if (!$this->_isAnythingChanged($oArticle, $aParams)) {
            return;
        }