View Issue Details

IDProjectCategoryView StatusLast Update
0005887OXID eShop (all versions)1.04. Content, static (register, contact etc.) pagespublic2014-09-25 13:06
Reportermhk 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.7 / 5.1.7 
Target Version4.7.14 / 5.0.14Fixed in Version4.7.14 / 5.0.14 
Summary0005887: cms-page cache is not updated when using smarty
Descriptionif smarty tags are implemented in cms-pages the cache has to be deleted manually to make the changes visible in frontend.

I tested in a new oxid installation (PE 4.8.7), and our live system (PE 4.8.1)

Steps To Reproduce1. add a new cms page with just text -> save ->view result in frontend
2. edit text -> save -> edit is visible in frontend
3. edit text -> add simple smarty code like [{$oViewConf->getBaseDir()}] -> save -> view result in frontend -> nothing changed -> cache file is not updated
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005628 resolvedaurimas.gladutis Changes in oxNews-Longdescription does not change in frontend 

Activities

FibreFoX

2014-09-19 16:52

reporter   ~0010173

Maybe correlated with this bug? https://bugs.oxid-esales.com/view.php?id=5825

aurimas.gladutis

2014-09-25 13:06

reporter   ~0010186

The problem is that parseThroughSmarty function was not forcing recompilation of news, cms pages and promotions long description templates. This was fixed by adding fourth parameter as true when parsing long descriptions like this:

$oUtilsView->parseThroughSmarty($oxlongdesc, $id, null, true);

Files that needs to be edited:
oxnews.php::getLongDesc()
content::getParsedContent()
oxactions::getLongDesc()
oxcategory::getLongDesc()

This way descriptions is recompiled even when blCheckTemplates is set to true.