View Issue Details

IDProjectCategoryView StatusLast Update
0005628OXID eShop (all versions)2.7. Customer infopublic2014-09-25 13:06
Reporterszdirk 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.1 / 5.1.1 
Target Version4.7.14 / 5.0.14Fixed in Version4.7.14 / 5.0.14 
Summary0005628: Changes in oxNews-Longdescription does not change in frontend
DescriptionIf any smarty-tags are set in oxnews__oxlongdesc further changes of this xolongdesc are not shown in frontend.
Steps To ReproduceOXID Demoshop 4.8.1:
1. Uncheck "Automatic detection of necessary Template re-compilation. Uncheck during normal operation for increased performance." in shop admin
2. Add any smarty tag, e.g. [{$oViewConf->getCurrentHomeDir()}] into any news (Admin - Customer Info - News)
3. Call that news in frontend
4. Change the news in admin (add one character etc.)
5. Changes are not shown in frontend

Additional InformationThis behaviour does also exist in older shop versions.
TagsNews, Smarty
ThemeBoth
BrowserAll
PHP Version5.2.6
MySQL Version5.0.33

Relationships

related to 0005887 resolvedaurimas.gladutis cms-page cache is not updated when using smarty 

Activities

aurimas.gladutis

2014-09-25 13:06

reporter   ~0010185

The problem is that parseThroughSmarty function was not forcing recompilation of news, cms pages and promotions long description templates. This was fixed by adding fourth parameter as true when parsing long descriptions like this:

$oUtilsView->parseThroughSmarty($oxlongdesc, $id, null, true);

Files that needs to be edited:
oxnews.php::getLongDesc()
content::getParsedContent()
oxactions::getLongDesc()
oxcategory::getLongDesc()

This way descriptions is recompiled even when blCheckTemplates is set to true.