View Issue Details

IDProjectCategoryView StatusLast Update
0005775OXID eShop (all versions)4.06. Language and translationspublic2015-07-08 09:44
Reportermboesing 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.5 / 5.1.5 
Target Version4.8.9 / 5.1.9Fixed in Version4.9.5 / 5.2.5 
Summary0005775: DefaultLanguage collabs language selection in frontend
DescriptionoxLang::processUrl terminates language selection logic.
DefaultLanguage will get deleted from created URL so non-SEO URL will created without the "lang=" parameter.

If your browser language differs from the default shop language, you can only visit the link in your default language.

Thats not smart.
Steps To Reproduce1. Set your browser to "english" and your default shop language to "german".
2. Delete all cookies and set your browser to "disable cookies" (however)
3. Visit your shop (yup, its english now)
4. Change language to the default shop language (german)
5. Browse through the shop
Additional Information- SEO-Links work fine since they relate to languages
- Non-SEO Links will be missing the "lang=" parameter for default language since it gets removed by "oxLang::processUrl"

Since my browser has cookies disabled, it wont store the language cookie tho and the Non-SEO Link Page will get displayed in my browsers language.

To fix this, you should always add this language parameter if the default language differs from the customers browser.
TagsLanguages, Session
ThemeAzure
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Relationships

related to 0006232 acknowledgedflorian.auer Language Url param added, even if there is only one language available. 

Activities

mboesing

2014-09-29 10:07

reporter   ~0010192

I've created a Pull Request on github since this bug is open for about 4 months and nothing happened.
https://github.com/OXID-eSales/oxideshop_ce/pull/163

arturas.sevcenko

2014-10-29 09:01

reporter   ~0010286

Fixed with pull request: https://github.com/OXID-eSales/oxideshop_ce/pull/163