View Issue Details

IDProjectCategoryView StatusLast Update
0005705OXID eShop (all versions)4.06. Language and translationspublic2014-07-14 12:45
Reportermarco_steinhaeuser 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.4 / 5.1.4 
Target VersionFixed in Version4.9.0_5.2.0_beta1 
Summary0005705: %s missing in several language keys
DescriptionWhen searching for untranslated keys in English in translate.oxidforge.org, I find the following:

AUCTMASTER_DO_EXPORTFILE2
DELIVERY_RDFA_ADVICE_END
DYNBASE_DO_DOWNLOAD
DYN_ECONDA_COPY
PAYMENT_RDFA_ADVICE_END

This is because in an English word order of a sentence, a var %s is placed at the end of a sentence so mostly the second key is left without a translation in the one or another key.

Example:

tpl: AUCTMASTER_DO_EXPORTFILE1 {$var} AUCTMASTER_DO_EXPORTFILE2

DE:
'AUCTMASTER_DO_EXPORTFILE1' => 'Konnte Exportdatei',
'AUCTMASTER_DO_EXPORTFILE2' => 'nicht schreiben',

EN:
'AUCTMASTER_DO_EXPORTFILE1' => 'Couldn't write export file',
'AUCTMASTER_DO_EXPORTFILE2' => '',

Correct:
'AUCTMASTER_DO_EXPORTFILE1' => 'Couldn't write export file %s',
[delete]'AUCTMASTER_DO_EXPORTFILE2' => '',
Additional InformationSee http://translate.oxidforge.org
Will do my best to fix it for the above named language keys with a GitHub pull request in order to achieve 100% translated keys for the standard languages we deliver.
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities