View Issue Details

IDProjectCategoryView StatusLast Update
0005425OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2014-03-04 11:25
Reportermidiane 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.3 / 5.0.3 revision 54408 
Target Version4.7.10 / 5.0.10Fixed in Version4.7.10 / 5.0.10 
Summary0005425: Discount works incorrect when using Articles with Select List
DescriptionHey there,

The discount works wrong for articles with select list:
The discount is ignoring the extra amount of the select list and is using the "basic" price instead.

Example:

-You have an article with a basic price of 50€
-If you choose this article from select list for ex. in different color
 it has an extra amount of 10€. This means the article costs 60€ in total.

-My discount rule is:
 Purchase Price: from 60€ to 9999999
 Discount: 10%

-As you can see the total of my shopping cart is 60€.
 But the Discount doesn't take effect. This is due to the fact that the discount
 is ignoring the extra amount. It only sees the basic price of the select list (50€).
 Because of this the discount is not using the correct starting point.

Is there any patch for this Oxid Version?
Additional InformationAlso tested in the Oxid Demoshop
TagsDiscount, Selection List
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

midiane

2013-09-30 10:01

reporter   ~0009119

Is there any patch for this Oxid Version?

Linas Kukulskis

2013-11-15 16:32

reporter   ~0009274

fixed basket summary calculation