View Issue Details

IDProjectCategoryView StatusLast Update
0005392OXID eShop (all versions)4.01. Database handlingpublic2014-03-04 11:25
ReporterAlpha-Sys 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.6 / 5.0.6 
Target Version4.6.7Fixed in Version4.6.7 
Summary0005392: Wrong article inheritance in subshops
DescriptionIf you have a mastershop (oxissupershop) and a subshop which is inherited from mastershop, articles are shown in admin and frontend in the subshop that should only assigned to the mastershop. The article is also in the db view of the subshop. Oxid EE 5.0.6. VERY CRITICAL! Please fix urgently.
Steps To ReproduceShop1 is the mastershop. Create a new subshop with the setting "Shop inherits all inheritable items (products, discounts etc) from it's parent shop.". The parent shop is of course Shop1.
Go to the mall tab of the subshop and deactivates "Inherit all products from parent shop". Switch to the mastershop and create an article. Do not assign the article to the subshop. Now switch to the subshop and go to the articles. The new article is also shown in the subshop and can be opened in the frontend of the subshop. The article is also in the db view of the subshop.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

hung

2013-09-06 09:45

reporter   ~0009039

Last edited: 2013-09-06 15:00

View 3 revisions

this seems to be caused by fixing 0004536?

tomas_liubinas

2013-09-09 15:47

reporter   ~0009060

As far as I see this behavior is not related to 0004536 fix.

The source causing this behavior is in oxShopsMetaData::getParentShopsBits() (line 125). The following lines puts the priority of inheritance to the initial shop option and not the config option:

if ( !$blIsInherited ) {
    $blIsInherited = $rs->fields[2];
}

The primary recommendation for fixing this bug would be changing the above condition to:
if ( is_null($blIsInherited) ) {
   //...
}