View Issue Details

IDProjectCategoryView StatusLast Update
0004536OXID eShop (all versions)1. ----- eShop frontend -----public2015-12-31 18:14
Reportertomas_liubinas 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.7 
Target Version4.6.7Fixed in Version4.6.5 revision 49955 
Summary0004536: Loading of items does not work for non-subshop items
DescriptionIn cases when you need to display or use items (eg. products for checkout) it should be possible to load item information from other subshops as well. Currently you can use only products from current subshops and this is wrong.
Additional InformationThe reason causing this problem is oxBase::load() method accessing information from subshop db view and not from the core table (main view).
Tagsshared basket, Subshops
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005424 resolvedaurimas.gladutis Product over the URL is accessible even if product is not assigned to the shop 

Activities

There are no notes attached to this issue.