View Issue Details

IDProjectCategoryView StatusLast Update
0005381OXID eShop (all versions)2.7. Customer infopublic2013-10-31 17:19
Reportermartinwegele 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.8 / 5.0.8 
Target Version4.7.10 / 5.0.10Fixed in Version 
Summary0005381: promotions are mixed up or not included in Azure
DescriptionThe promotions on the start page of the Azure theme are mixed up.
Additionally it is not documented and it is quite difficult to find out anything about it from the sourcecode. Actually changing the promotions on the start page should be a simple task for a shop owner. But because of this bug it is not.
Also most of the promotions of the demodata are not included in the Azure theme and can thus be removed (incl. getters from application/controllers/start.php?)
Steps To ReproduceTry to change the aticle that is displayed as "Week's Special" on the start page:
1. Log in to admin
2. Go to Customer Info -> Promotions
3. Select the "Angebot der Woche" = "Week's Special"
4. Assign another product
5. Go to the homepage: There was nothing changed.
Additional InformationThis issue was probably never changed/fixed since the introduction of the Azure theme in 4.5.0.
http://forum.oxid-esales.com/showthread.php?t=10627#post63657
TagsPromotion
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0003673 resolvedarturas.sevcenko Naming of promotions is not consistent in admin, azure and basic 
related to 0005526 confirmed not working actions and promotions 

Activities

martinwegele

2013-10-24 10:29

reporter   ~0009193

I have given this a little bit more thought and I think it would be nice to have a widget for actions which you can easily integrate anywhere into your template. The desired action could be loaded according to a parameter you pass to that widget. I know that this is more of a feature request now but in my opinion that would make loading actions in a template a lot easier than using another method for every action. That way there is no need to create a new method for every action you want to load in a template and actions could be integrated anywhere in a template without having to check in the controller if the method exists. Also a lot of superfluous methods could be removed.