View Issue Details

IDProjectCategoryView StatusLast Update
0005336OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2014-09-09 13:23
Reportermartinwegele 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.6 / 5.0.6 
Target Version4.8.8 / 5.1.8Fixed in Version4.9.0_5.2.0_RC1 
Summary0005336: wrong calculations in basket when using voucher
DescriptionIf you use a voucher (=coupon?) the calculation of the sums and VAT in the basket is really strange (cp. screenshot):
1. Total Products (net) (incl. discount)
2. plus VAT 19% from total products net price (incl. discount)
3. Total products (gross) (NOT including discount)
4. Coupon
5. Grand total (incl. discount)
Is this an intended behaviour? At least the first two positions should be calculated WITHOUT discount.
Steps To ReproduceIn the demoshop create a voucher with e.g. 75 discount abs.
Leave everything else empty / as is.
Generate the coupon numbers.
Put a product into the basket in the frontend (should probably be more expensive than the discount).
Add the coupon=voucher to the basket.
See.
TagsBasket, Order
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

martinwegele

2013-08-13 11:17

reporter  

cart_voucher_vat.png (54,622 bytes)
cart_voucher_vat.png (54,622 bytes)

svetlana

2013-12-02 13:53

reporter   ~0009324

Prices should be displayed same as in example with discount (attached picture)

svetlana

2013-12-02 13:53

reporter  

pic1.png (33,015 bytes)
pic1.png (33,015 bytes)

Linas Kukulskis

2014-09-09 13:23

reporter   ~0010133

updated checkout and email templates