View Issue Details

IDProjectCategoryView StatusLast Update
0005254OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2015-03-19 14:04
ReporterEggSupport 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version4.7.5 / 5.0.5 
Target Version4.9.4 / 5.2.4Fixed in Version 
Summary0005254: Selectlists are not considered correctly
DescriptionThere is a problem with the correct calculation from selectlists.
It's reconstructable in your demo shop and with simmilar problems in our live system.
Weve got the bug since version 4.7.5.
Steps To ReproduceCreate selectlists with +1000 abs and -1000 abs and try it for example with Kite FLYSURFER SPEED3

Total 1.439,10 € both.
Additional InformationTry to put
http://bestprotection.de/shop/Koerperschutzsysteme/Schutzwesten/UEberziehschutzwesten/Polizei-Schutzweste-BATEX.html

with variant Gr. M and Schutzklasse SK2 +100 € into the basket. The sum is correct for the whole order and payment process, _but_ in the backend (and oxorder, oxorderarticles) the selectlist are not considered.

OXID CE 4.7.6
TagsSelection List
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0004624 acknowledged Order recalculation does not use discounts/taxes which were valid when order was made, but current ones 
related to 0005737 acknowledged selectlists are handled wrong if name or value contains a comma followed by a space 

Activities

EggSupport

2013-06-27 11:09

reporter   ~0008845

Sorry, selectlist are _not_ beeing considered correctly

EggSupport

2013-07-12 12:48

reporter   ~0008899

Last edited: 2013-07-15 16:58

View 2 revisions

aggrosoft create a little fix, see attached

---
doesnt work all the time... maybe there more bugs

edit 15-07-13

EggSupport

2013-07-12 12:57

reporter  

oxorderbug.zip (1,567 bytes)

EggSupport

2013-07-17 20:18

reporter   ~0008926

okay antother problem

selectlist doesnt work with variants...(multidimensional) the price calculation crash if you change for example the pay date.

EggSupport

2013-07-18 10:45

reporter   ~0008928

--> https://bugs.oxid-esales.com/view.php?id=4624

Workaround
--> http://forum.oxid-esales.com/showthread.php?t=18930&page=5#post127751

tomas.lygutas

2013-07-22 11:25

reporter   ~0008931

Do you mean that variants are not considered during order recalculation in backend? (e.g. updating amount of ordered items)
We were trying to reproduce this bug, all selectlist prices are correctly calculated in basked, checkout process and later correctly displayed in backend. But in backend if order is updated (amount changed and order recalculated) then selectlist prices are not considered correctly.

Could you specify the case with variants (multidimentional) that is not working properly for you as well?

EggSupport

2013-07-26 23:14

reporter   ~0008938

No, its the same you explain. Selectlist prices are not correctly calculate in backend if there any change in the order and the system recalculate.

EggSupport

2013-08-12 13:41

reporter   ~0008949

sorry, but how long it will take until the solution?

EggSupport

2013-09-16 11:09

reporter  

cmselectionlistsrecalculate.zip (2,446 bytes)

EggSupport

2013-09-16 11:10

reporter   ~0009085

attached a new fix -
cmselectionlistsrecalculate.zip

jurate.baseviciene

2013-09-18 10:46

reporter   ~0009092

Reminder sent to: EggSupport

Hi,

 As we saw, you already submitted a complete solution for this issue. If you feel fancy, you'd also have the possibility to contribute your changes directly to our GitHub repository on https://github.com/OXID-eSales/oxideshop_ce/. [^] Please leave a note there with the bug number you fixed so we can close this issue in the bug tracker."

Best regards

martinwegele

2015-03-19 10:27

reporter   ~0010812

Last edited: 2015-03-19 13:54

View 2 revisions

The attached fix by aggrosoft (oxorderbug.zip) is to change one line in oxorder::_setOrderArticles():
/* AGGROSOFT BUG FIX , USE COMMA INSTEAD OF SPACE TO APPEND VAR SELECT */
                $oOrderArticle->oxorderarticles__oxselvariant = new oxField( trim( $sSelList.', '.$oProduct->oxarticles__oxvarselect->getRawValue() ), oxField::T_RAW );

This will separate the selected variant clearly from name-value-pairs which come from select lists. This is important for the shop to be able to "find" the last selection value again.

If the selected selection contained a price surcharge this will not be taken into account correctly during recalculation of the order in the admin panel. This is a "child issue" of 0004624 and a possible fix is in cmselectionlistsrecalculate.zip (by Julian Rauscher from OXID Certified Solution Partner Business Level - Commodule UG in Freiburg).

QA

2015-03-19 14:04

administrator   ~0010815

Last edited: 2015-03-19 14:05

View 2 revisions

The issue could not be reproduced with the information provided so far. The "steps to reproduce" of the original report seem to imply that the config option " Support Price Modifications by Selection Lists " (bl_perfUseSelectlistPrice) was not activated in advance. This is not a bug.

In note 8926 the reporter said that there is (only?) a problem with (multidimensional) variants and the recalculation in the admin panel (~ 0004624). The reporter confirmed in note 8938 that this is the wrong behaviour of this issue. However we were unable to reproduce the behaviour in the described way in a PE 4.9.3: If " Support Price Modifications by Selection Lists " is activated and a variant article with selection list is bought all prices are correct. Also setting the payment date or altering the amount in the order will not result in wrong prices (e.g. the price surcharge being ignored or such). Therefore this issue will be closed.
Please reopen it with clear instructions on how to reproduce the behaviour if you think that the error persists.