View Issue Details

IDProjectCategoryView StatusLast Update
0005125OXID ERP InterfaceOXID ERP Interface - subpublic2015-05-04 15:19
Reportermartinwegele 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.11.1_54476 
Target VersionFixed in Version2.12.0 
Summary0005125: Revision number of shop is cast as int
DescriptionAfter moving to GitHub pkg.rev contains a string of numbers and letters, e.g. 6cda1e4d8b4c19047960cdce632a54033e6fe2ff for 5.0.5.
But in OXERPCompatibility::getPkgRevision this is cast as an integer!
Please check if this could cause problems.
Additional Information public function getPkgRevision($sBasePath = null)
    {
        $sFile = (!$sBasePath?getShopBasePath():$sBasePath).'/pkg.rev';

        if (is_readable($sFile)) {
            return (int) trim(file_get_contents($sFile));
        }
        // TODO: return newest (HEAD)
        return 9999999;
    }
TagsGit

Relationships

related to 0005124 resolvedLinas Kukulskis OXID eShop (all versions) getRevision casts revision number to int 

Activities

andrius.silgalis

2013-08-29 12:01

reporter   ~0009006

Since shop version 4.6 CE and 5.0 PE/EE there is no revision appended to return string from getShopVersion().