View Issue Details

IDProjectCategoryView StatusLast Update
0005072OXID eShop (all versions)4.09. SEO, SEO URLpublic2014-02-20 12:45
ReporterBergfreunde 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.7.4 / 5.0.4 revision 57063 
Target Version4.8.5 / 5.1.5Fixed in Version 
Summary0005072: SEO-URLs for CMS without category-assignment are wrong
DescriptionAt application/models/oxseoencodercontent.php:76 you just check if there is a category-assignment (which is almost always the case). The category-assignment still remains if the oxtype is changed.

To ensure a correct SEO-URL for CMS without category-assignment it should be checked if oxtype == 2.

TagsCategory, CMS
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

has duplicate 0003535 resolvedarturas.sevcenko CMS-Snippet 

Activities

jurate.baseviciene

2013-04-16 08:09

reporter   ~0008611

Reminder sent to: Bergfreunde

Hi,

Thanks a lot for submitting this issue, but we can not reproduce the case. . Could you please give us more details how to reproduce this case?

Best regards

Bergfreunde

2013-04-16 08:32

reporter   ~0008612

1. Create CMS
2. assign it to a category
3. go to seo-tab (should be category/cms-title/
4. changed it from type "category" to "snippet"
5. save it
6. got to seo-tab, delete the url and save it

--> the category is still in the url

jurate.baseviciene

2014-02-20 12:45

reporter   ~0009551

bug is closed as duplicate of 0003535