View Issue Details

IDProjectCategoryView StatusLast Update
0005040OXID eShop (all versions)1.03. Basket, checkout processpublic2017-06-12 18:03
Reporterhenrik.steffen 
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionno change required 
PlatformallOSallOS Versionall
Product Version4.7.4 / 5.0.4 revision 57063 
Target Version4.9.5 / 5.2.5Fixed in Version 
Summary0005040: Newsletter subscription is cancelled if user orders as guest without registration
DescriptionIf you subscribe to the newsletter without opening an account, your subscription will be cancelled, if you order as a guest.


This is irritating for shop customers. Especially for those, who never want to open an account or make a registration.

We've had an exapmle here, were a customer has regularly ordered from a shop, without ever registering himself. He claims, that he had subscribed several times, but suspected that he got unsubscribed again, everytime he placed a new order.

We tried to reproduce this in demoshop, and the customer is actually right.
Steps To Reproduce1) subscribe to newsletter
2) make an order as a guest, without enabling newsletter again
3) you are unsubscribed
TagsNewsletter, User Management
ThemeAzure
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Relationships

related to 0003091 closeddainius.bigelis user without registration loses all assigned usergroups if he orders a second time 
related to 0006146 acknowledgedflorian.auer Newsletter Checkbox in Checkout Progress doesn't show the actual Status of the newsletter subscription of guest users 

Activities

henrik.steffen

2013-11-04 08:50

reporter   ~0009207

This problem is really serious!

We've found out, that if you order as a guest today, and decide to subscribe to the newsletter later, you'll have no chance to do so.

You will not even received the opt-in mail from the shop. Instead, the unsubscription routine will be executed, because the shop can't successfully load the user object of the guest. So, even worse, if you subscribed to the newsletter with your guest-order, you will be unsubscribed!


Please fix as soon as possible. This is included even in OXID version 4.8.0 / 5.1.0 !!

THank you!

FibreFoX

2013-11-04 10:03

reporter   ~0009208

The problem is the handling of newsletter-mailing and users, they are not separated.

Other bugs, that may interfere with this one:
0004463, 0004838, 0004460

henrik.steffen

2013-11-08 13:40

reporter   ~0009258

Please ignore my comment of 2013-11-04 08:50

Actually, the problem was when I was testing, that oxSession::setVar( "blDBOptInMailAlreadyDone", true ); was set after my first try.

However, the problem about guest users getting unsubscribed from the newsletter when ordering again as a guest still exists.

QA

2015-05-18 16:41

administrator   ~0010966

Last edited: 2015-05-18 16:43

View 2 revisions

This doesn't make sense at all. Current behavior of the shop is right. It also gives the user a possibility to unsubscribe from the newsletter during checkout.

henrik.steffen

2015-05-18 17:09

reporter   ~0010967

Hello,
this bug is still present in current OXID eShop 4.9.4 and can be reproduced at any time in the demo shop at:

https://demoshop.oxid-esales.com/community-edition


1) subscribe to newsletter or order as a guest while enabling the newsletter
2) confirm newsletter subscription by clicking e-mail link
3) user has been assigned newsletter group and opt-in successfully confirmed
4) now, clear all cookies or use a different browser to make another order with the same e-mail-address, again as a guest, without registering and WITHOUT enabling newsletter again
5) the previously subscribed e-mail-address has now been unsubscribed from the newsletter. Both the usergroup assignment was deleted, and the opt-in checkbox was unchecked

I can't imagine, that this is a desired behavior

florian.auer

2015-05-19 10:13

reporter   ~0010970

There are multiple options how to handle this:

1) Leave it as it is (unsubscribe guest user, if checkbox is not checked)
2) Switch behaviour from "unsubscribe" to "don't change anything", if checkbox is not checked (might have some legal issues)
2) Check on the fly during checkout, if user is already subscribed to newsletter and adjust the UI according to the result (might have some legal issues)
3) Move the newsletter subscription part to the "thank you" page, where the E-mail address is known and the shop can check if the user is already subscribed to the newsletter

In any case, this is a feature change/request to me, which has to be checked especially from a legal point of view. However, we are planning to slim down the shop core and extract stuff to modules. The newsletter feature does not belong to the core domain of the OXID eShop, and usually third party solutions such as Inxmail or Mailchimp or the like are used for newsletter management.