View Issue Details

IDProjectCategoryView StatusLast Update
0004750OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2012-12-07 15:07
Reporteritsabug 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.5.8 revision 42471 
Target VersionFixed in Version 
Summary0004750: Wrong payment discount when direct item addition to other discount, based on 0003581
DescriptionSorry if im missing this issue in the list, but i can reproduce what seems to me like 0003581, in oxid 4.5.8 pe/ce.
Seems to me like it was gone with release of 4.6.0.
But i don't find any info on patch/fix.

Advanced payment discount mixed with another non payment discount can lead to wrong calculations if the item is added to the discount directly.
Steps To Reproduce1. Activate and use advanced payment with like -3% skonto.
Activate rules 1-4 for this payment discount.
2. Create a discount with like 40% reduction and don't add any user/items/cat to it so that it works as global discount.
3. Buy an item.
4. Go to Basket. Go through until step 3 and select advanced payment.
5. Go back to basket. You're gonna see the listed discount and the payment discount showing the right results.
6. In admin, add the article item you have in basket to your newly created discount.
7. Go back to basket and refresh it.

You'll see that the advanced payment discount CHANGES HIS VALUE.
I can reproduce this on 4.5.8 naked ce and pe.
As i mentioned, this seems to be fixed in 4.6.X.
Would you mind telling me, when/how/where this was fixed so that i can fix this myself? Thank you very much.

TagsDiscount
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Relationships

duplicate of 0003587 resolvedtomas_liubinas Category or product specific discounts round the discount value BEFORE multiplying x amount. 

Activities

itsabug

2012-11-28 09:05

reporter   ~0008007

Ah sorry to bother you.
Found it: 0003587
Sorry again.

jurate.baseviciene

2012-11-28 09:14

reporter   ~0008008

Closed as duplicate of 0003587.