View Issue Details

IDProjectCategoryView StatusLast Update
0003581OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2012-12-07 15:07
Reporterc.meggers 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version4.5.1 revision 38045 
Target VersionFixed in Version 
Summary0003581: Incorrect new customer discount in combination with prepayment
DescriptionIn the calculation of the discount for new customers and the choice of prepayment the discount is calculated incorrectly.

The checkbox for including "Discounts" in the Payment Methods price calculation settings is ignored. so Discounts are not included in Payment Methods price anyway - no matter is checkbox is marked or not. This is the bug and will be fixed.
Steps To Reproduce1. I select an article with variants and set the price at 10€. (In the oxid demo shop).
2. I create a new discount: 5% off for new customers, applies to all customers who have not yet shopped.
3. I assign the discount to german customer.
4. I add the items of the shop.
5. I add the group of users that has not yet purchased.
6. In the next step, I specify that customers who prepay, get 3% discount to the basket value (assignment: all user groups and all people in all countries).
7. I add an item to the basket.
8. The discount is not reported yet.
9. I choose prepayment as the method of payment.
10. In the total calculation the discount of the prepayment is incorrect (see screenshot).
The discount for new customers is correct. The discount for prepayment is incorrect. 0,42€ are charged but it has to be 0,40€.
The 3% discount for prepayment has to be credited to the entire basket. But it´s credited to the regular price of the item and the shipping. The discount for new customer is not considered. So the total cost is incorrect.
TagsDiscount
ThemeAzure
BrowserAll
PHP Versionany
Database Versionany

Activities

c.meggers

2012-02-14 14:27

reporter  

screenshot_10.png (123,680 bytes)
screenshot_10.png (123,680 bytes)

dainius.bigelis

2012-02-28 15:37

reporter   ~0005826

Reminder sent to: c.meggers

Hi,

After testing your described test case we found out that:
1. the checkbox for including "Discounts" in the Payment Methods price calculation settings is ignored. so Discounts are not included in Payment Methods price anyway - no matter is checkbox is marked or not. This is the bug and will be fixed.
2. But we cannot reproduce the issue with:
"<...>If I do not fill the box "purchasing quantity" and "shopping value" (quantity or value 0), the discount will not be assigned to all items and quantities."
If newly created discount is active and those fields are not filled - the discount is active for all the products in eShop. But discount works _only_ if there is nothing else assigned to the discount, like Country or User group. If there is any assignment - then discount works only according to those restrictions (so not for entire shop and all products, but only what fits according to restrictions). When country is assigned - discount is not applied until user logs into eShop, so his country can be checked.
Please correct me if I'm wrong and missunderstood the case in part #2.

Thank you for your report.

c.meggers

2012-02-28 17:23

reporter   ~0005828

Thank you for your Feedback!

Concerning point 2.
I crosschecked the issue again in the demoshop and couldn't reproduce it anymore. The discounts seem to work correctly as described. Sorry for the trouble!

dainius.bigelis

2012-03-16 10:16

reporter   ~0006015

I edited the description about the point#1, which must be fixed.

dainius.bigelis

2012-04-05 16:26

reporter   ~0006190

Reminder sent to: c.meggers

Hi,

Something really strange happened :) We cannot reproduce the issue with "Discount" including in Payment Costs anymore. I even checked on several versions, like 4.5.1, 4.5.9, 4.5.8 and 4.5.7 - in all those versions Payment Costs calculation reacts on the checked or UNchecked the option for Discount (in your described case it's 0.42 or 0.40 EUR, depending on the option).
I checked several cases, but cannot reproduce this issue.
Could you please check this case also and confirm that you cannot reproduce this also OR tell how to reproduce that in more details (your described case step-by-step also works well for us)?