View Issue Details

IDProjectCategoryView StatusLast Update
0004581OXID eShop (all versions)4.08. Cachepublic2012-12-10 13:39
Reporterd3 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0004581: content::getParsedContent() missing oxid argument
DescriptionIn certain circumstances content pages contain cached data.
For example:
view the imprint page saves .....%ox%3A0.php
view an other content page loads .....%ox%3A0.php (same file)

Both contents have to contain smarty code in it!

Since 4.6.0 there is a new method called getParsedContent
The method is a wrapper for:
oxUtilsView::getInstance()->parseThroughSmarty( $this->getContent()->oxcontents__oxcontent->value );

But we are missing here, the 2nd parameter $sOxid:
public function parseThroughSmarty( $sDesc, $sOxid = null, $oActView = null, $blRecompile = false )

So this is better:
oxUtilsView::getInstance()->parseThroughSmarty( $this->getContent()->oxcontents__oxcontent->value, $this->getContentId() );
Steps To Reproduceput some smarty code ([{$oViewConf->getSelfLink()}]) into CMS pages (oxagb, oximpressum, ...).
view them after another.
both should contain the same text
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Relationships

duplicate of 0004298 resolvedsaulius.stasiukaitis Sometimes wrong content loaded on CMS page 

Activities

leofonic

2012-10-02 15:28

reporter   ~0007530

duplicate of 0004298

dainius.bigelis

2012-10-02 15:35

reporter   ~0007531

Closed as duplicate of 0004298