View Issue Details

IDProjectCategoryView StatusLast Update
0004332OXID eShop (all versions)7. --- Other tools --------------public2015-05-04 14:57
Reporterray 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.3 revision 47975 
Target Version4.6.6 revision 54646Fixed in Version4.6.6 revision 54646 
Summary0004332: oxchkversion mentions "modified" and "unknown" on fresh installation
DescriptionSeveral users reported in forums, that on a fresh installation of CE the oxchkversion mentions one "modified" and one "unknown" file, but does not tell which ones.

I could imagine that those are config.inc.php and maybe .htaccess - but those never can be untouched after installing.

This behaviour is irritating users a lot.
Steps To Reproduceinstall a fresh eShop - check with oxchkversion
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0004118 resolvedmichael_keiluweit oxchkversion does not work with 4.6.0 
related to 0003343 resolveddainius.bigelis oxchkversion detects many files as version mismatch 

Activities

aurimas.gladutis

2012-12-13 10:33

reporter   ~0008118

Last edited: 2012-12-13 10:33

View 2 revisions

Hi, config.inc.php and .htaccess are not included in cheking files. We have added unknown files listing, as it was not listed at all. As for showing of modified files, we coult not reproduce it. Maybe you could give us screenshot or link to the thread at forum?

To show unknown files, oxchkversion.php oeShopCheck::run() line 561 should be changed to:
} elseif ($oXML->res == 'UNKNOWN') {
   $sMessage = 'Unknown';
   $sColor = "green";
}

aurimas.gladutis

2012-12-18 12:23

reporter   ~0008156

Reminder sent to: ray

Hi, we have investigated this case and the case with unknown files. However, you have mentioned that there are some "modified" files not being displayed. As we could not reproduce this case, maybe you could give any more information on when this case happens?

ray

2012-12-18 13:15

reporter   ~0008161

it just mentioned "xy files modified" but did not list them

Anyway, with new version and 4.7.x I did not see any mistakes, so maybe it is solved now?

aurimas.gladutis

2012-12-18 13:50

reporter   ~0008166

I see, so we are closing this ticket then. If there will be any further problems with it, please reopen it.