View Issue Details

IDProjectCategoryView StatusLast Update
0004287module PayPalmodule PayPal - subpublic2012-08-20 10:35
Reporterray 
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.0.1 
Target VersionFixed in Version2.0.2 
Summary0004287: aborting PayPal-payment prevents choosing another payment method
DescriptionIf you are choosing PayPal as payment method while checkout, then abort payment and go back to shop, you can not choose any other payment method until you have finished checkout. This of course throws an error, as no payment was made through PayPal. But an email about the order in shop is sent - the order does not show up in admin.
After that you can choose any other payment method and finish again without errors and then the order is shown in admin.

Logging out and logging in again does not change this behaviour, you need to finish first and after the error shows up you can go on.
Additional Informationreportet in forums, reproduced by a second user
 - CE 4.5.9_43186
 - PHP 5.3
 - Paypal Version 2.0.1

http://forum.oxid-esales.com/showthread.php?t=14402&page=8#post96902
TagsNo tags attached.

Relationships

has duplicate 0004366 resolvedsvetlana OXID eShop (all versions) payment selection in order step 4 shows wrong payment method 

Activities

ray

2012-07-30 07:42

reporter   ~0007134

another user with same problem:
http://forum.oxid-esales.com/showthread.php?t=15546

mart

2012-07-30 09:40

reporter   ~0007135

For me this is an critical issue since it does not allows the user to finish the payment.

What are the plans for resolving this?

mart

2012-07-31 22:36

reporter   ~0007173

Could someone have a look on this issue?

arturas.sevcenko

2012-08-01 08:27

reporter   ~0007174

@mart will have a look

d3

2012-08-03 12:13

reporter   ~0007219

we can confirm the problem. If you aborting the payment on the paypal site you came back to the shop (correct). But if you change your payment method in step3, paypal is already selected in step4.

rimvydas_paskevicius

2012-08-03 15:08

reporter   ~0007226

Updated PayPal code to fix this problem

ray

2012-08-04 00:25

reporter   ~0007227

sorry - needed to reopen to add a comment...

Where to get the fix? With next oePayPal version? When is this released?

solidevolution

2012-08-06 09:15

reporter   ~0007232

Please fix this critical behavior asap. Thx!

mart

2012-08-08 13:12

reporter   ~0007267

@rimvydas_paskevicius: Could you please update the 'Fixed in Version' field since. Again four days are past and we have no response from you guys.

solidevolution

2012-08-15 09:42

reporter   ~0007313

Any news here?! We're still waiting for an update ...

dainius.bigelis

2012-08-20 09:53

reporter   ~0007342

Hi,

The issue is fixed and will be released together with new PayPal module version 2.0.2 (together with other important fixes). Currently we are working on this new version, which will be released ASAP.