View Issue Details

IDProjectCategoryView StatusLast Update
0004282OXID eShop (all versions)4.09. SEO, SEO URLpublic2012-12-10 13:34
Reporterd3 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.2 revision 46646 
Target VersionFixed in Version4.6.6 revision 54646 
Summary0004282: no check for characters in sSEOuprefix
DescriptionThere is a problem with sSEOuprefix in OxSeoEncoder.
If you save sSEOuprefix with some special character, the shop is not usable and will display lots of errors or an "Internal Server Error".

Warning: preg_replace() [function.preg-replace]: Compilation failed: range out of order in character class at offset 14 in /xxx/xxx/core/oxstrregular.php on line 212



Steps To ReproduceTry it with these examples:

1) w--
2) www.test-shop.de

Use the methode setPrefix() in OxSeoEncoder to test it.

TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

aurimas.gladutis

2012-11-19 14:05

reporter   ~0007898

The problem was that php versions lower than 5.3 method preg_quote did not escaped - character. If your php version is higher than 5.3 and the problem still persists, please give us exact php version which you are using.