View Issue Details

IDProjectCategoryView StatusLast Update
0004161OXID eShop (all versions)2.4. Administer productspublic2014-02-21 14:08
Reporterleofonic 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version4.6.1 revision 45706 
Target Version4.8.5 / 5.1.5Fixed in Version 
Summary0004161: Seo Entry for Article in Category is not removed when category is unassigned
DescriptionIf you unassign a category from an article seo entry is not deleted
Steps To Reproduce1. View article in detail view in frontend
2. Remove the current category from article (tab extended/assign categories)
3. Reload article, it is still visible
Additional Informationcause: admin/oxajax.php, line 635:
            $sQ = "delete from oxseo where oxtype='oxarticle' and oxobjectid='%s' and
                   oxshopid='{$sShopId}' and oxparams in ('" . implode( ",", oxDb::getInstance()->quoteArray( $aCatIds ) ) . "')";

implode $aCatIds is in single quotation marks, but is already quoted.
TagsAJAX, Category, Products
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0004648 resolvedtomas_liubinas Moving articles invalidates old URL 

Activities

leofonic

2012-12-07 15:55

reporter   ~0008077

This was resolved in 4.6.2

jurate.baseviciene

2014-02-21 14:07

reporter   ~0009583

Hi,
We can't reproduce such issue. Probably is fixed with other change. If in the future this bug will be reproduced please bug status change to "Reopen". And please written for more details how bug need reproduce.

Best regards,