View Issue Details

IDProjectCategoryView StatusLast Update
0004122OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2015-05-04 14:15
Reporterdainius.bigelis 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.10 revision 44222 
Target VersionFixed in Version4.7.1 / 5.0.1 revision 52468 
Summary0004122: Wrong error message is displayed, when coupon applied in basket with products from category "Skip all negative Discounts"
DescriptionCreate an category with selected option "Skip all negative Discounts". Then put any product from this category to the basket.
In the basket try to apply the coupon (which would give any discount on product) - insert the number to the field and click "Submit coupon".
Then you will get the error message that:
"Purchase prace below 0,- is not allowed."

That message is incorrect, because even if coupon would be applied - the total of the basket would not be below 0,00 EUR. So this is triggered with the option "skip all negative Discounts"

In this case it should display proper message, that coupon cannot be applied for the products, because Discounts cannot be applied to these articles.
Steps To ReproduceIn example the coupon with 10EUR discount was inserted.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0003920 resolveddainius.bigelis Discount is still substracted in excluded category 
related to 0003540 resolvedLinas Kukulskis Error message in basket after switching currencie and with activated coupon 

Activities

dainius.bigelis

2012-06-05 16:25

reporter  

coupon_error.png (80,803 bytes)
coupon_error.png (80,803 bytes)

Linas Kukulskis

2012-11-12 14:29

reporter   ~0007824

removed rudimental vouchers negative discount check; removed ability enter negative voucher discount;