View Issue Details

IDProjectCategoryView StatusLast Update
0003920OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2012-12-07 15:07
Reportercoarsy 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version4.5.10 revision 44222 
Target VersionFixed in Version 
Summary0003920: Discount is still substracted in excluded category
DescriptionIf you have an category like "sale" and there are a lot of reduced articles in it, you dont want that special discounts(absolute or percent) are substracted from this articles again.

For this behaviour you can set the option "Skip all negative Discounts(Discounts, Vouchers, Delivery ...)" in the category you want exclude from special discounts.

But this option doesnt work, articles in the special category are still discounted.
Steps To Reproduce1. Create a category like "sales"
2. Set the option: "Skip all negative Discounts(Discounts, Vouchers, Delivery ...)"
3. Put reduced articles (Price < UVP) into this category
4. Activate an percent discount for example 10 %
5. Put reduced product from sales category into basket
6. Look into the basket -> Product will become 10 % additional discount and thats the wrong behaviour.
TagsDiscount
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0004122 resolvedLinas Kukulskis Wrong error message is displayed, when coupon applied in basket with products from category "Skip all negative Discounts" 

Activities

dainius.bigelis

2012-06-05 16:19

reporter   ~0006779

Reminder sent to: coarsy

Hi,

sorry, but we cannot reproduce this case. We tried on eshop 4.5.10 and 4.6.0, with Discounts on Products and on Categorie of the product, also with coupons - but always it gives the same result, when the "Sale" category has marked the checkbox "Skip all negative Discounts" - it shows message in the basket:
"** Discounts are not applied to these articles"

(see screenshot attached).
Could you try to reproduce this case on our demoshop:
http://demoshop.oxid-esales.com/enterprise-edition/ ?

Best regards,

dainius.bigelis

2012-06-05 16:19

reporter  

no_discounts.png (62,278 bytes)
no_discounts.png (62,278 bytes)

dainius.bigelis

2012-06-05 16:27

reporter   ~0006781

There is another issue what we found during testing, that incorrect error message was displayed in such case. Issue reported here as 4122.

Linas Kukulskis

2012-11-12 14:34

reporter   ~0007825

unable to reproduce, discounts not applied