View Issue Details

IDProjectCategoryView StatusLast Update
0004071OXID eShop (all versions)1. ----- eShop frontend -----public2012-12-10 14:37
Reporterray 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.6.0 revision 44406 
Target VersionFixed in Version 
Summary0004071: new code prevents displaying individual persparams in basket
Descriptionsince in 4.6.0 was implemented following code into views/oxcmp_basket.php - the persparams-fields in basket are only shown if persparam "details" is present and has a value:

$aPersParam = ( isset( $aProductInfo['persparam'] ) && is_array( $aProductInfo['persparam'] ) && strlen( $aProductInfo['persparam']['details'] ) )?$aProductInfo['persparam']:null;

no problem when using old code (as condition for "details" is not added):

$aPersParam = isset( $aProductInfo['persparam'] )?$aProductInfo['persparam']:null;
Steps To Reproduceadd individual persparam - fields
use some while ordering, but do not enter a value into the "details" - field
Additional Informationis there any deeper reason for adding this condition?
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0002867 resolvedLinas Kukulskis when adding article with persparam from list, persparam field not shown in basket 
related to 0003907 resolvedLinas Kukulskis Separate entries of the same product are shown in the basket 

Activities

dainius.bigelis

2012-06-05 14:47

reporter   ~0006777

There were fixes made for issues 0002867 and 0003907, also related with persparams.
After the fix for 0003907, there was this check for empty value, because there is no other way how to compare the same product with persparam, when product is added from different places in eShop (i.e. lists and details view).
In standard eShop source code there is one persparam implemented. In this case if you also have one,just renamed to other title - then just rename it also in the mentioned source code:
<...> ['persparam']['details']

But if somebody has several persparams implemented in eShop - this is more custom change then and then you should take care about that part - override also the handling of these persparams with proper logic, how to compare the values in your case.