View Issue Details

IDProjectCategoryView StatusLast Update
0003907OXID eShop (all versions)1.03. Basket, checkout processpublic2012-12-10 13:22
Reporterdainius.bigelis 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.0_RC2 
Target VersionFixed in Version4.6.0 revision 44406 
Summary0003907: Separate entries of the same product are shown in the basket
DescriptionWhen added two units of the same product to the basket (adding one by one), which has input fields for the label, products in the basket are shown as separate entries (as would be different products). See screenshot for details.
If there are no entries in label field for those products - then products should be merged to one entry with increased quantity.

Pay attention to the fact, that if label is inserted for the product before adding it to the basket - then product should be displayed as separate entry.
Steps To ReproduceAdd one "Transportcontainer THE BARREL" to the basket. Go to basket, click on "Update". Then go back to Main page and add the same product to the basket once again. Go to basket - you will see two entries of the same product, with quantity 1 (that's wrong).
If you would click "Update" - then products would be merged to one entry with quantity 2 (should work like this since beginning).

TagsOrder
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0004071 resolveddainius.bigelis new code prevents displaying individual persparams in basket 

Activities

Linas Kukulskis

2012-04-24 14:31

reporter   ~0006419

changed perparams emptiness check in basket recalculation

dainius.bigelis

2012-04-24 14:41

reporter  

double_entries.png (81,578 bytes)
double_entries.png (81,578 bytes)