View Issue Details

IDProjectCategoryView StatusLast Update
0004058OXID eShop (all versions)4.09. SEO, SEO URLpublic2015-06-09 13:43
Reportermarco_steinhaeuser 
PrioritylowSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version4.6.6 revision 54646 
Target Version4.9.5 / 5.2.5Fixed in Version 
Summary0004058: duplicate content
DescriptionUsing a crawler , I found out that this crawler apparently was able go generate a URL that already existed before for the same page by adding the number "1" to it:

e.g.:
/tag/glue/1/
/en/tag/glasses/1/
/tag/index/1/
/tag/huefttrapez/1/
(please see the screenshot attached for more details)

Please note:
- only tags are affected
- this pages seem to be generated with crawler only (couldn't reproduce it manually, you can only access these URLs when the crawler has generated it before) - means: a search engine crawler would do the same and produce DC with it! On some place, there seem to be a link that puts the wrong URL together.
TagsSEO, Tags
ThemeAzure
BrowserAll
PHP VersionNot defined
Database VersionNot defined

Relationships

related to 0003678 resolvedvilma_liorensaityte Tag-Pagination in "Back to Article" is not converted to SEO-Link and is returning 404 
related to 0003723 acknowledged CMS pages with plain-param are indexed 

Activities

marco_steinhaeuser

2012-05-17 18:05

administrator  

dc.png (184,156 bytes)
dc.png (184,156 bytes)

updown

2012-05-18 01:06

reporter   ~0006627

This is due to the patch of this bug:

https://bugs.oxid-esales.com/view.php?id=3678

Developers should think a minute about given solutions, before making their own decisions without considering such effects like mentioned here. The problem is, that in the official patch, the $iPage is not checked as in my proposal-patch (see bug report above).

QA

2015-05-22 09:14

administrator   ~0010984

Reminder sent to: marco_steinhaeuser

Hi Marco,

could you please give us some more information on how to reproduce this issue? I used severals Sitemap generators, but wasn't able to.

Regards!