View Issue Details

IDProjectCategoryView StatusLast Update
0004049OXID eShop (all versions)3.1. Design, GUI, UXpublic2012-06-06 09:58
Reporterleofonic 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.0 revision 44406 
Target VersionFixed in Version4.7.0_5.0.0_beta1 
Summary0004049: X-UA-Compatible is ignored because it is wrapped in conditional comments
DescriptionIn base.tpl:
    <!--[if IE]>
    <meta http-equiv="X-UA-Compatible" content="IE=9" >
    <![endif]-->
This does not seem to work as intended
Steps To Reproduce- Install Shop on local machine
- Open locally with IE9
- Compatible Mode is active and icon "Compatible Mode" is shown
- remove conditional comments <!--[if IE]> and <![endif]-->
- IE9 Mode is active and icon "Compatible Mode" is not shown
TagsNo tags attached.
ThemeAzure
BrowserInternet Explorer 9.x
PHP Versionany
MySQL Versionany

Activities

updown

2012-05-16 23:14

reporter   ~0006622

Just remove the cond-comments.

BTW: This is basic knowledge for years. A good explanation is here:
http://ovms.co/2011/06/ie-x-ua-compatible-multiple-versions-conditional-comments/
"In theory, an alternative would involve wrapping the X-UA-Compatible <meta> tag with some of IE’s proprietary conditional comments (condcoms). Unfortunately, this would present a “chicken-and-egg” problem, as the effective browser version (ie. v8 for IE8, v7 if EmulateIE7-mode) must be determined before any condcoms are evaluated: this means the X-UA-Compatible tag cannot then change the browser version (for example, to “EmulateIE7?)"

vaidas.matulevicius

2012-05-21 16:52

reporter   ~0006660

You don't need to remove conditional comments, just make sure that IE isn't set to view Intranet sites in compatibility mode by default:
1) On your keyboard, press "ALT" to make the menu bar show
2) Select "Tools", and click "Compatibility View Settings"
3) Check that "Display intranet sites in Compatibility View" is not checked.
You may need to restart your browser for the change to take effect.

leofonic

2012-05-22 14:15

reporter   ~0006666

Well right now, the compatible tag is ignored. I think it is not the purpose of the compatible tag to be ignored by the browser.

To reproduce in internet zone:
- Go to demoshop: you see the compatibility mode button (x-ua tag broken)
- Go to microsoft.com: you see no compatibility mode button (x-ua tag working)

updown

2012-05-23 11:34

reporter   ~0006669

Last edited: 2012-05-23 11:35

View 2 revisions

Slowly for the devs:

Conditional Comments do generally NOT work with meta X-UA-Compatible-entries or other http-equivs - this has nothing to do with inter- or intranet.

"http-equiv" is technically the same like sending a document-header: It is considered BEFORE the html-document itself is parsed. But Conditional Comments NEED to be parsed to work. So either it is parsed too late and the X-UA-Compatible-meta therefore will be ignored, or the X-UA-Compatible-meta is ignored BECAUSE it is in conditional comments.

One way or the other: It will be ignored! As it is now, it has the same effect like removing this entry completely, it has no effect at all.

If you want to have an effect, you have to remove the conditional comments. There is no other way!

marco_steinhaeuser

2012-05-23 11:57

administrator   ~0006670

> Slowly for the devs:

Your input is very valuable but this is not the forum. Please write your comments in a respectful and friendly tone.

updown

2012-05-23 12:10

reporter   ~0006671

@marco_steinhaeuser: I apologize if this reads unfriendly, it was not meant so. But respect has to be earned. The handling of this trivial bug is a farce, considering the lack of basic knowledge, considering the simplicity of evaluating it and considering the time the Azure-template exists.

So either you accept my kind of tone in such cases, or I'm finished with any more future inputs. This acceptance includes this comment.

ray

2012-05-23 14:42

reporter   ~0006675

Sorry - I have no sympathy or understanding for that kind of behaviour.

As ye sow, so shall ye reap!

updown

2012-05-23 19:27

reporter   ~0006678

Last edited: 2012-05-23 19:33

View 3 revisions

While we're at it, you should think about changing this to 'edge'

<meta http-equiv="X-UA-Compatible" content="IE=edge">

for making each IE-version use its individual newest mode (IE8 as 8, IE7 as 7).

Also, IE10 (actual beta) has to be checked for possible side-effects.

@Ray: Sympathy is not needed for professionality, this is simply about the attitude to make the best out of everything. Sometimes some external shit-rain is necessary as a fertilizer for making things growing better. Otherwise ones could sow as much as you like, there'll be not much to reap...

vaidas.matulevicius

2012-06-06 09:58

reporter   ~0006790

Conditional statements removed and changed from 'IE=9' to 'IE=Edge'.

Fix for lower versions of eShop 'base.tpl':
<!--[if IE]>
<meta http-equiv="X-UA-Compatible" content="IE=9" >
<![endif]-->
Change to:
<meta http-equiv="X-UA-Compatible" content="IE=Edge" >