View Issue Details

IDProjectCategoryView StatusLast Update
0003990OXID eShop (all versions)2.3. Extensions (modules, themes)public2012-12-10 13:33
Reporterjurate.baseviciene 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.6.0 revision 44406 
Target VersionFixed in Version 
Summary0003990: If modules directrory was changed in debug modules then fatall error is displayed
DescriptionA fatal error message is displayed after module directory was changes in debug modules

Go to admin:
1) Need to active modules for example "Test1",
2) Need to active "Module debug",
3)Go to "Extensions"->"Modules" click on the "Modules debug", then click on the tab Debug;
4)In the tab "Debug->"Installed Modules" you can to see that is installed "Test1" modules (info => oxid/test6/view/myinfo6);
5) Need to rename directory (from "info => oxid/test6/view/myinfo6" to new directory which is not exist in modules "Test1", "info => oxid/test6test/view/myinfo6");
6) Then click on the tab "Installed Shop Modules";
In the "Installed Shop Modules" is displayed notes:

(There are modules which are registered in eShop, but module directory is missing.Do you want to remove all module information including config options and block information for templates?)
Yes No

7) Need to click button "Yes";
And then is displayed fatal error.
Warning: Illegal offset type in isset or empty in /mnt/hgfs/www/oxideshop_features/source/core/oxmodulelist.php on line 309





TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0003955 resolvedvilma_liorensaityte after removing old module entries, some php warnings occurs. 

Activities

jurate.baseviciene

2012-05-03 21:42

reporter  

Warning.png (31,499 bytes)
Warning.png (31,499 bytes)

leofonic

2012-05-15 10:38

reporter   ~0006606

maybe duplicate of 0004001

ray

2012-05-23 23:02

reporter   ~0006680

and/or maybe related to this one https://bugs.oxid-esales.com/view.php?id=3955