View Issue Details

IDProjectCategoryView StatusLast Update
0003955OXID eShop (all versions)2.3. Extensions (modules, themes)public2012-12-10 13:33
Reportermichael_keiluweit 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.0 revision 44406 
Target VersionFixed in Version4.6.1 revision 45706 
Summary0003955: after removing old module entries, some php warnings occurs.
DescriptionNew shop module handling asked me to remove old paypal entries (4.5.9). I clicked the button "yes" and those warnings occurs:

Warning: Illegal offset type in isset or empty in /efihfhpp/www.efiretestshop.oxid-esales.com/core/oxmodulelist.php on line 315

Warning: Illegal offset type in isset or empty in /path/to/the/shop/core/oxmodulelist.php on line 315

Warning: Illegal offset type in isset or empty in /path/to/the/shop/core/oxmodulelist.php on line 315

Warning: Cannot modify header information - headers already sent by (output started at /path/to/the/shop/core/oxmodulelist.php:315) in /path/to/the/shop/core/oxutils.php on line 1197
Additional InformationOutput of installed shop-modules:


Warning: Illegal offset type in isset or empty in /efihfhpp/www.efiretestshop.oxid-esales.com/core/oxmodulelist.php on line 315

Warning: Illegal offset type in isset or empty in /path/to/the/shop/core/oxmodulelist.php on line 315

Warning: Illegal offset type in isset or empty in /path/to/the/shop/core/oxmodulelist.php on line 315

Warning: Cannot modify header information - headers already sent by (output started at /path/to/the/shop/core/oxmodulelist.php:315) in /path/to/the/shop/core/oxutils.php on line 1197





oxorder
invoicepdf/myorder
oepaypal/core/oepaypaloxorder
order
oepaypal/views/oepaypalorder
payment
oepaypal/views/oepaypalpayment
wrapping
oepaypal/views/oepaypalwrapping
oxviewconfig
oepaypal/views/oepaypaloxviewconfig
oxaddress
oepaypal/core/oepaypaloxaddress
oxuser
oepaypal/core/oepaypaloxuser
oxbasket
oepaypal/core/oepaypaloxbasket
oxarticle
oepaypal/core/oepaypaloxarticle
oxcountry
oepaypal/core/oepaypaloxcountry
oxstate
oepaypal/core/oepaypaloxstate
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0004001 resolvedvilma_liorensaityte Wrong Methodcall in 
has duplicate 0003990 closedjurate.baseviciene If modules directrory was changed in debug modules then fatall error is displayed 

Activities

michael_keiluweit

2012-04-30 15:25

developer   ~0006489

Last edited: 2012-04-30 15:26

View 3 revisions

first I have updated the shop from 4.5.9 to 4.6.0 and then I tried to update PayPal.

saulius.stasiukaitis

2012-05-14 18:43

reporter   ~0006599

This warning occurs because array used as a key in another array in method “_removeFromLegacyModulesArray”: isset($aLegacyExt[$sDeletedExtId]).
This is wrong behavior because variable $sDeletedExtId shouldn’t be array. This variable is array because of wrong call in method “cleanup”. Instead off “getDeletedExtensions” method “getDeletedExtensionIds” should be called.