View Issue Details

IDProjectCategoryView StatusLast Update
0003919OXID eShop (all versions)1.03. Basket, checkout processpublic2014-06-20 09:03
Reporterramunas.skarbalius 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.0_RC1 
Target Version4.9.0_5.2.0_beta1Fixed in Version4.9.0_5.2.0_beta1 
Summary0003919: Address is not validated whn you go directly to step 3
DescriptionWhen you login, add items to the basket and press CHECKOUT.
Your directly sent to STEP 3. (skipping step 2 with addresses).
This causes a problem when the address is missing some required fields.

On the other hand, if you instead pressing checkout go directly to STEP 2.
It doesn't allow you to go to STEP 3 because fields are not valid/missing.
Steps To Reproduce1) login to eshop
2) add some article to basket
3) remove required field information from database, or just add new required fields which was empty and not required.
4) click on the basket button check out (when user can go to step 3)
5) So if required field empty you can buy article.
TagsAddress, Basket
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

aurimas.gladutis

2014-06-20 09:03

reporter   ~0009984

changed oxinputvalidator::checkRequiredFields() to use oxRequiredFieldsValidator for validation. It is also used in oxorder when finalizing order.

Now the user is still allowed to go to the payment step when new required field is added, but is not allowed to finish the order, as the message saying that not all of the address fields are correct is shown. Both billing and shipping address fields are checked.