View Issue Details

IDProjectCategoryView StatusLast Update
0003835OXID eShop (all versions)6. ------ Setup -------public2012-06-26 17:02
Reporterray 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version4.5.9 revision 43186 
Target VersionFixed in Version 
Summary0003835: Add check for installed Suhosin Patch and "suhosin.get.max_value_length" > = 1024 to system requirements
DescriptionIf suhosin.get.max_value_length is set too low, it does not submit the user data and the database can not be created in step 420.
The problem is, that the standard value for this setting is 512 - which is way too low to submit all necessary data. Then you get an error similar to this "Access denied for user 'www-data'@'localhost' (using password: NO)' " which does not show the user and password you have set while setup.

It would be great to include the check for Suhosin into system requirements.
Steps To Reproduceinstall a shop on a server with suhosin.get.max_value_length = 512
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0002362 resolvedarturas.sevcenko Refactor setup to not use the URL for sending params 

Activities

dainius.bigelis

2012-06-26 17:02

reporter   ~0006989

Duplicate of 0002362