View Issue Details

IDProjectCategoryView StatusLast Update
0002362OXID eShop (all versions)6. ------ Setup -------public2012-06-28 12:34
Reporterdainius.bigelis 
PriorityhighSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.0 revision 17976 
Target VersionFixed in Version4.5.12 revision 52682 
Summary0002362: Refactor setup to not use the URL for sending params
DescriptionWhen running setup in CE or PE editions and submitting license number at the last step, often happens that setup directs user to the first setup page again.
That's because all setup params are collected in the URL and on last step it exceeds the maximum allowed length in URL and setup is broken.
It happens only when suhosin is installed on apache, but it's param suhosin.get.max_value_length is too small and should be increased.
Refactor setup to not use the params in the URL.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

has duplicate 0003835 closedvilma_liorensaityte Add check for installed Suhosin Patch and "suhosin.get.max_value_length" > = 1024 to system requirements 

Activities

dainius.bigelis

2012-06-26 17:49

reporter   ~0006991

The issue is fixed in 4.6 version, but not in 4.5. Please fix it also in this version for next 4.5 Patch.

arturas.sevcenko

2012-06-28 12:34

reporter   ~0007008

Now also fixed for next 4.5 Patch.