View Issue Details

IDProjectCategoryView StatusLast Update
0003479OXID eShop (all versions)3.1. Design, GUI, UXpublic2012-07-16 14:15
Reportermarco_steinhaeuser 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.0_beta2 
Target VersionFixed in Version4.7.0_5.0.0_beta1 
Summary0003479: CMS page "Credits" doesn't appear under http://www.myshop.com/Credits
DescriptionIn an email between Sandro, Ralf and me we agreed on Feb 24th 2010, that the Credits page will get an URI like this: http://www.myshop.com/Credits.

Presently, the URL to the page looks like this:
http://www.myshop.com/en/Credits

Further, this CMS page is language dependent. That means - if you switch English off, this Credits page is gone.

Please provide a Credits page in English language that can be accessed via http://www.myshop.com/en/Credits and that doesn't disappear when you switch English off.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

dainius.bigelis

2012-01-05 17:09

reporter   ~0005588

Last edited: 2012-01-06 13:22

View 2 revisions

The goal is to have the same Credits page available on any language (even if English language is disabled). Possible to solve that by:
1. creating cms page with present text, and generate the same urls to that page in all the languages. OR
2. create a View which takes the same content, not depending from current language.

One more rule:
the page itself is not allowed to be removed and can be accesses by everybody (even a search engine crawler) by hitting www.myshop.com/Credits
But shop owner would be allowed to remove the link in footer of the shop which leads to this page.

marco_steinhaeuser

2012-01-18 13:29

administrator   ~0005610

Last edited: 2012-01-18 13:32

View 2 revisions

I'd prefer solution #2 for the following reason:
If the same content is available in all languages it could perhaps (not 100% sure) lead to problems with duplicated content even if you forward to the same URI.

"One more rule" is not relevant for fixing this bug. We will add this info on http://goo.gl/bxG3n as soon as this bug is fixed. No artificial difficulties to remove the page needed ;)
Maybe mark the URL as "fixed" by default.

ramunas.skarbalius

2012-06-18 09:07

reporter   ~0006914

If cms page with ident oxcredits does not exist, breaks the page.
Because in template is trying to get this page object which is not loaded.

Problem is in smarty plugin: block.oxifcontent.php, where is checking if object is loaded.

lines which needs to fix:
 1. line: 53 - trying to load object;
 2. line: 67 - checking if object loaded or just ident is "oxcredits").

Linas Kukulskis

2012-07-16 14:15

reporter   ~0007100

solution 2 is done. fixed smarty plugin bug