View Issue Details

IDProjectCategoryView StatusLast Update
0003123OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2015-05-04 14:15
ReporterHelmut L. 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.1 revision 38045 
Target VersionFixed in Version4.6.0_beta2 
Summary0003123: Used vouchers are not shown in e-mail
DescriptionIf you use a voucher with an order, in the emails that are send after you complete the order, the used vouchers are not shown.
In the emails are only the row with the titles shown and below them a % sign.
Steps To ReproduceMake an order and use a voucher.
Additional InformationIn the email templates the voucher values are tried to get from $voucher->oxmodvouchers__... but since the table name is oxvouchers the template gets only empty values for the vouchers.
To correct this the calls need to be changed to $voucher->oxvouchers__...

This is in both themes, in the html and plain emails for the customer and the owner:
/out/azure/tpl/email/html/order_cust.tpl
/out/azure/tpl/email/html/order_owner.tpl
/out/azure/tpl/email/plain/order_cust.tpl
/out/azure/tpl/email/plain/order_owner.tpl
/out/basic/tpl/email/html/order_cust.tpl
/out/basic/tpl/email/html/order_owner.tpl
/out/basic/tpl/email/plain/order_cust.tpl
/out/basic/tpl/email/plain/order_owner.tpl
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

has duplicate 0003251 closedsvetlana Order sum calculation not correct/transparent when voucher code is used 
related to 0003383 resolvedarvydas_vapsva Coupon numbers are not included in order emails (0003123 isn`t completely fixed) 

Activities

Helmut L.

2011-08-10 13:55

reporter   ~0004976

I just recognized another bug in the templates for the plain emails, which also prevents the vouchers from being displayed.
The foreach to output the vouchers uses the variable $vouchers, but this variable is never set.

Here the foreach should use $order->getVoucherList(), like it is done in the templates for the html emails.