View Issue Details

IDProjectCategoryView StatusLast Update
0002865OXID eShop (all versions)4.08. Cachepublic2012-12-10 13:39
Reportertjungcl 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionPast development 
Target VersionFixed in Version4.5.2 revision 38481 
Summary0002865: noncachable user components are not inititialised in initNonCacheableComponents
Descriptionif you use aUserComponents to register an own user component like
   protected $_aUserComponentNames = array('mycomp' => 1);
and set the blNotCacheable flag to 1, the user component is not initialised in cache calls.

The reason is, that user components and oxid components are not merged in initNonCacheableComponents() but only in init(). And in init() they are not initialised (in cache call) because init() thinks, it has already be done in initNonCacheableComponents()

Workaround until fixed: write the user component directly into the $_aComponentNames
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0001721 resolvedvilma_liorensaityte Missing functionality for custom component handling 

Activities

birute_meilutyte

2011-05-12 13:54

reporter   ~0004552

@developers: check from source code side if such issue exist

tjungcl

2011-07-22 09:06

reporter   ~0004876

since with the latest update the usercomponents now can be configured va the config.inc.php, I rechecked this issue too - but its still not functional.

non cachable compontents added as usercomponent are not initialised in cached pages and therefore dont work.

The reason why it doesnt work is still well explaned above.